Closed Bug 1577388 Opened 4 months ago Closed 3 months ago

Page zoom reset after switching tabs from etherpad

Categories

(Firefox :: General, defect, P1)

x86_64
Windows 10
defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 + verified
firefox71 --- verified

People

(Reporter: birtles, Assigned: enndeakin)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

STR:

  1. Open https://pad.mozilla.org/p/7LVooPJ3OM (note: Mozilla auth required. This will not reproduce with the public instance of etherpad)
  2. Zoom the page by using Ctrl+mouse wheel to, say, 150%.
  3. Switch to another tab
  4. Switch back to the etherpad tab

Expected results:
Page zoom is preserved

Actual results:
Page zoom is reset to 100%.

I asked others on slack to reproduce this but they couldn't so it's possibly at least Windows specific.

I could not reproduce with beta but I could reproduce with a fresh profile in Nightly so I don't believe it is profile / extension related.

I can reproduce with Firefox Developer Edition (70.0b1), also on Windows.

Is this a regression?

Flags: needinfo?(brian)

Hello! Here is the regression range made using Windows 10x64:

Last good revision: 91c42888cf7fa67f2b9d08d0e62cb203ad1e6619
First bad revision: 70e7c3ef6cae2266147c38ad250692ffe84aec26
INFO: Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=91c42888cf7fa67f2b9d08d0e62cb203ad1e6619&tochange=70e7c3ef6cae2266147c38ad250692ffe84aec26

If more information is needed please let me know. Thank you!

Flags: needinfo?(brian)
Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(enndeakin)
Priority: -- → P1
Regressed by: 1558919

[Tracking Requested - why for this release]:
We shouldn't ship this.

Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Flags: needinfo?(enndeakin)
Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2bdd2503fbdb
use the top browser when receiving zoom messages, r=mconley
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Hi Neil, is this ready for a Beta approval request?

Flags: needinfo?(enndeakin)

Comment on attachment 9091412 [details]
Bug 1577388, use the top browser when receiving zoom messages, r=mconley

Beta/Release Uplift Approval Request

  • User impact if declined: Zoom level gets reset on some pages when switching to another tab and back. Automated test has not yet been made.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Steps are listed in bug.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): None
  • String changes made/needed: None
Flags: needinfo?(enndeakin)
Attachment #9091412 - Flags: approval-mozilla-beta?

Comment on attachment 9091412 [details]
Bug 1577388, use the top browser when receiving zoom messages, r=mconley

Fix for new regression in 70, OK for uplift for beta 70.

Attachment #9091412 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Hello,
Reproduced the issue with Firefox 70.0a1 (20190828214452) on Windows 10x64.
The issue is verified fixed with Firefox 71.0a1 (20190916155843) and Firefox 70.0b7 (20190916074538) on Windows 10x64. Etherpad page zoom is kept after switching to another tab and back.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Regressions: 1590445
You need to log in before you can comment on or make changes to this bug.