Closed Bug 1577436 Opened 1 year ago Closed 5 months ago

Addressbook xpcshell tests time out after bug 1572324

Categories

(MailNews Core :: Address Book, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 71.0

People

(Reporter: jorgk-bmo, Unassigned)

References

(Regression)

Details

TEST-UNEXPECTED-TIMEOUT | xpcshell-jsaddrbook.ini:comm/mailnews/addrbook/test/unit/test_basic_nsIAbDirectory.js | Test timed out
TEST-UNEXPECTED-TIMEOUT | xpcshell-jsaddrbook.ini:comm/mailnews/addrbook/test/unit/test_bug387403.js | Test timed out
TEST-UNEXPECTED-TIMEOUT | xpcshell-jsaddrbook.ini:comm/mailnews/addrbook/test/unit/test_basic_nsIAbCard.js | Test timed out
TEST-UNEXPECTED-TIMEOUT | xpcshell-jsaddrbook.ini:comm/mailnews/addrbook/test/unit/test_bug448165.js | Test timed out
TEST-UNEXPECTED-TIMEOUT | xpcshell-jsaddrbook.ini:comm/mailnews/addrbook/test/unit/test_bug1522453.js | Test timed out
TEST-UNEXPECTED-TIMEOUT | xpcshell-jsaddrbook.ini:comm/mailnews/addrbook/test/unit/test_cardForEmail.js | Test timed out
TEST-UNEXPECTED-TIMEOUT | xpcshell-jsaddrbook.ini:comm/mailnews/addrbook/test/unit/test_collection.js | Test timed out
TEST-UNEXPECTED-TIMEOUT | xpcshell-jsaddrbook.ini:comm/mailnews/addrbook/test/unit/test_collection_2.js | Test timed out
TEST-UNEXPECTED-TIMEOUT | xpcshell-jsaddrbook.ini:comm/mailnews/addrbook/test/unit/test_db_enumerator.js | Test timed out
TEST-UNEXPECTED-TIMEOUT | xpcshell-jsaddrbook.ini:comm/mailnews/addrbook/test/unit/test_jsaddrbook.js | Test timed out
TEST-UNEXPECTED-TIMEOUT | xpcshell-jsaddrbook.ini:comm/mailnews/addrbook/test/unit/test_mailList1.js | Test timed out
TEST-UNEXPECTED-TIMEOUT | xpcshell-jsaddrbook.ini:comm/mailnews/addrbook/test/unit/test_notifications.js | Test timed out
TEST-UNEXPECTED-TIMEOUT | xpcshell-jsaddrbook.ini:comm/mailnews/addrbook/test/unit/test_nsAbAutoCompleteMyDomain.js | Test timed out
TEST-UNEXPECTED-TIMEOUT | xpcshell-jsaddrbook.ini:comm/mailnews/addrbook/test/unit/test_nsAbAutoCompleteSearch1.js | Test timed out

First seen when bug 1572324 landed:
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=9c50784bfcdcd94d844a7be36fa259a1a183ba7f&selectedJob=263447628

Sadly xpcshell is all red due to other issues on that push.

Flags: needinfo?(geoff)

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/2cdd8691d001
switch off xpcshell-jsaddrbook on Mac. rs=bustage-fix,jorgk

Keywords: checkin-needed

It appears that something in my current patch for bug 1576525 fixes the problem.

Depends on: 1576525
Flags: needinfo?(geoff)

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/42a0e80821fe
Re-enable tests fixed by bug 1576525; rs=me DONTBUILD

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 71.0
You need to log in before you can comment on or make changes to this bug.