Closed Bug 1577466 Opened 3 months ago Closed 3 months ago

[Protections Panel] Social tracking protection subview header is not correct when there is a site exception

Categories

(Firefox :: Site Identity, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox70 --- verified

People

(Reporter: nhnt11, Assigned: nhnt11)

References

(Blocks 1 open bug)

Details

(Whiteboard: [privacy-panel][skyline])

Attachments

(1 file)

We are using the notBlocking string only when the pref is disabled, we should also be checking hasException.

Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/c21434a80df3
[Protections Panel] Check hasException state when setting social tracking subview title. r=johannh
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Flags: qe-verify+

I’ve reproduced this issue with Fx 70.0a1 (2019-08-29) on Windows 10 x64.
The issue is verified fixed with Fx 71.0a1 (2019-10-14) and Fx 70.0b14 across platforms (Windows 10 x64, macOS 10.14, Ubuntu 18.04).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.