Closed Bug 1577527 Opened 1 year ago Closed 8 months ago

Long usernames are wrongly scrolled after they are edited

Categories

(Firefox :: about:logins, defect, P3)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 74
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- disabled
firefox70 --- wontfix
firefox74 --- verified

People

(Reporter: cmuntean, Assigned: jaws)

References

Details

Attachments

(2 files)

Attached image long username.gif

[Affected Versions]:

  • Nightly 70.0a1

[Affected Platforms]

  • All Windows
  • All Mac
  • All Linux

[Prerequisites]

  • Have a Firefox profile with multiple logins saved.
  • Have a saved login that has a very long username,.

[Steps to reproduce]:

  1. Open the latest Nightly browser with the profile from prerequisites.
  2. Navigate to "about:logins" page.
  3. Click on one of the saved logins that has a very long username.
  4. Click the "Edit" button and add a few characters at the end of the username.
  5. Click the "Save" button and observe the username input.

[Expected results]:

  • The username is correctly displayed and is not scrolled.

[Actual results]:

  • The username is scrolled.

[Notes]:

  • The issue is not reproducible when creating new logins.
  • Attached a screen recording with the issue.
Priority: -- → P3
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Version: 70 Branch → unspecified

Mass removing [skyline] and [passwords:management] from about:logins bugs which are no longer useful.

Whiteboard: [passwords:management] [skyline]
Assignee: nobody → mcrawford
Status: NEW → ASSIGNED
Attachment #9119570 - Attachment description: Bug 1577527 - The long usernames are wrongly scrolled after are edited r?MattN → Bug 1577527 - The long usernames are wrongly scrolled after they are edited r?MattN
Summary: The long usernames are wrongly scrolled after are edited → Long usernames are wrongly scrolled after they are edited
Assignee: mcrawford → jaws
Attachment #9119570 - Attachment is obsolete: true
Attachment #9119570 - Attachment description: Bug 1577527 - The long usernames are wrongly scrolled after they are edited r?MattN → Bug 1577527 - Reset the horizontal scroll position of the username field when toggling on/off editing. r?MattN
Attachment #9119570 - Attachment is obsolete: false
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8e2091a51ea6
Reset the horizontal scroll position of the username field when toggling on/off editing. r=sfoster
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 74

I have verified this issue and is no longer reproducible. Tested using the latest Nightly 74.0a1 build (Build ID:20200209215935) on Windows 10 x64, Mac 10.15 and Arch Linux x64.

  • The horizontal scroll position of the username is reset after it's edited and saved.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.