Closed Bug 1577602 Opened 1 year ago Closed 1 year ago

input type=number on Windows shows two very small arrow buttons (height=4.5px each)

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: jaws, Assigned: jaws, NeedInfo)

References

Details

Attachments

(12 files)

Attached image 2019-08-29_1423.png

See attached screenshot

David, you mentioned that you spent a bit of time looking into the button sizing. The patch looks fine and improves things for larger number inputs, but do you have any thoughts on this?

Flags: needinfo?(dbaron)

The patch seems like a good approach to me (although I didn't review carefully); it seems to be doing basically the same thing I was thinking in bug 1169203 comment 6.

I'd just note that it's worth testing across platforms, and with both 1 and 2 being the ratio of CSS pixels to device pixels (e.g., because I know that on Ubuntu's default (I think?) theme the buttons actually stick out of the input a little bit when the resolution implies 1 CSS pixel == 1 device pixel), and probably also at different zooms.

Flags: needinfo?(dbaron)

Hey Jonathan, is there something that you're waiting on me for before you finish the review?

Flags: needinfo?(jwatt)

No, I've just been away. Sorry for the delay.

Flags: needinfo?(jwatt)
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ee9061d6a2a0
Allow spinner buttons to grow to full size in input[type=number]. r=jwatt
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Regressions: 1580512

Hi, This issue is Verified as Fixed on Windows 10 and Ubuntu 18.04 but it seems on Mac OsX 10.15 the arrows remain unchanged, I will attach a screenshot from the latest Nightly build. I saw no difference from Release 70, to this Nightly build, How should we proceed with this can someone please take a look ?

Flags: needinfo?(jwatt)
Attached image Screenshot MAC.jpg
Duplicate of this bug: 1554573
You need to log in before you can comment on or make changes to this bug.