Closed Bug 1577853 Opened 2 years ago Closed 2 years ago

If a mailing list has a really long name, it will begin to cut off the bottom of the OK / Cancel button

Categories

(Thunderbird :: Address Book, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: thee.chicago.wolf, Unassigned)

Details

Attachments

(2 files)

Attached image cut-off-buttons.png

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0 SeaMonkey/2.57

Steps to reproduce:

I have a mailing list created in my address book whose name is 34 characters long. I noticed when I was about to delete a user from it that the OK / Cancel buttons are slightly cut off at the bottom.

Actual results:

To test if it would further cut off more of the button(s), I created a test Mailing List with a very long name. The buttons do get cut off more. See attachment.

Expected results:

The buttons should not get cut off.

Was this good in 68? If not I’m pretty sure this is a duplicate

You use any scaling on a highres monitor? Richard, can you give further advice.

Flags: needinfo?(richard.marti)

(In reply to Wayne Mery (:wsmwk) from comment #1)

Was this good in 68? If not I’m pretty sure this is a duplicate

I just tried to roll back to 68 from 69b4 to test but it's complaining about the current profile not being backwards compatible. I tried starting with -p but no dice. =\

I hesitate to create a new profile for fear that if this is profile related, I'd want to test it against the existing profile as opposed to a new one. Anything I can do to force it to use the existing profile and be on 68?

-p -allow-downgrade

(In reply to Jorg K (GMT+2) from comment #2)

You use any scaling on a highres monitor? Richard, can you give further advice.

When I filed the bug report, it was happening on my work PC. At home, this is not reproing for me so something on my work PC is amiss.

But as for setup, nope, nothing but a plain vanilla setup on fairly dated hardware. No scalling, zooming, hidpi monitor. Is there something I can check to make sure it's not accidentally scaling and me not knowing? Could be that I fat-fingered a Window+key combo and did something wonky.

(In reply to Jorg K (GMT+2) from comment #4)

-p -allow-downgrade

Thanks. I'll try on Tuesday when I get back to my office PC.

Yes, it's only scaling that comes in mind. When you test it, could you also look on which length the overflow begins? The screenshot shows a name that is very long and I don't think such exists in the real world.

Flags: needinfo?(richard.marti)

What I am thinking of are things like
Bug 324426 - confirmation dialogue taller than screen when using "Delete All" / "Detach all" with many attachments, list truncated
Bug 1497902 - Delete attach message box cut buttons accept cancel, because of toolkit scaling issue
and
Bug 953280 - 'Ok' and 'Cancel' buttons cropped --> xul Bug 1063940 - modal dialogs window size doesn't fit/stretch properly, e.g. 'Fonts' dialog in preferences: Buttons 'OK', 'Help' and 'Cancel' cut off/cropped

Component: Untriaged → Address Book
Attached image no-issue-in-68.png

(In reply to Richard Marti (:Paenglab) from comment #7)

Yes, it's only scaling that comes in mind. When you test it, could you also look on which length the overflow begins? The screenshot shows a name that is very long and I don't think such exists in the real world.

Yes, I agree the list name is not likely to be so long in the real world but in the instances where someone might have a loner list name than what I currently have, it'll crop up and look askew.

Seems like with 68.0, it's not cutting off OK or Cancel as in 69.0b4. So, maybe not a scaling issue?

So now this is getting even more bizarre. After downgrading to 68.0 x64 and using -p -allow-downgrade to launch, I decided to see if and where things broke by installing 69.0b1, b2, b3 and b4 in sequential order. After installing each version, I checked the test mailing I'd created and OK / Cancel buttons are normal looking in each and every sequential version. So while it's presently WFM, could downgrading and then upgrading again have fixed anything? This makes no sense and makes me feel like I'm going nuts. =\

That is odd. SO if I understand you correctly Arthur, the dialog is now displaying properly?

In 68 and up?

Flags: needinfo?(thee.chicago.wolf)

(In reply to Benjamin Flanagin from comment #12)

That is odd. SO if I understand you correctly Arthur, the dialog is now displaying properly?

In 68 and up?

Yep, you got it. It makes zero sense. As you can see from the 1st image, it was happening and then magically not after downgrade then upgrade. I guess we can close this for now as WFM unless you want me to check some other items?

Flags: needinfo?(thee.chicago.wolf) → needinfo?(benjamin)

I'm fine with closing it. It can always be reopened if it becomes an issue again.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(benjamin)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.