Closed Bug 1577923 Opened 1 year ago Closed 1 year ago

Megabar should use tab navigation to switch between search engines, like separate search box

Categories

(Firefox :: Address Bar, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1437524

People

(Reporter: yoasif, Unassigned)

References

Details

Enabled the megabar on my install, and found that tabbing behavior is not what I expect based on my usage of the separate search box.

STR:

  1. Enable megabar
  2. Do Ctrl-l
  3. type in a query
  4. hit "tab" on keyboard

What happens:

The first suggestion is selected.

Expected result:

The first search engine suggested in "this time search with" should be selected, tabbing again should select the next. Hitting enter should search with the selected search engine.

Users should be able to navigate within search suggestions with arrow up and arrow down like in the separate search box.

The address bar always allowed to move through results using tab, consistency with the search bar is not a goal.
This is pretty much a duplicate of bug 1437524, with no relation with the megabar, afaict, the behavior is the same with or without the megabar. There is still discussion ongoing about what to do with tab, but UX for now wants tab to keep moving through results to be consistent with other browsers.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1437524

The address bar always allowed to move through results using tab, consistency with the search bar is not a goal.

Yeah, but this doesn't really make a whole lot of sense. The separate search box does make sense. We already know that less than 1% of nightly users rely on this functionality.

I would think internal consistency should be a goal generally, unless there is a very good reason to break it - I don't see any good reason here - tab here works unlike every UI control across every OS I have used.

There is still discussion ongoing about what to do with tab, but UX for now wants tab to keep moving through results to be consistent with other browsers.

I just tried Safari and GNOME Web. They don't do much useful with tab. I could understand if you are pushing for bug 782557 - but tab doing what it does in the other major browser (let's be real -- pretty much every other browser is a clone of Chromium anyway) doesn't make sense there either!

According to https://docs.google.com/document/d/1Dk_U-zXiMFynKOYYKrS6VKUXrON_ta2mYnAyHa-Uvc0 it wasn't even part of the design of the omnibox and was added by an external contributor -- wouldn't it be ironic if it was a Firefox switcher exporting this weird behavior to Chromium? I guess it goes to show that Chromium is also not immune from doing weird things for no discernible reason.

You are right that this isn't specifically a megabar issue - but the reason I opened this bug is because in all honesty, because I do have the separate search bar enabled, I basically never noticed or even attempted to tab to the other search engines in previous versions of the awesomebar.

megabar makes search engines really visible, and it requires users to do some VERY weird user interactions if they actually want to use the one off searches the way it looks like they ought to:

  1. Do Ctrl-l or click into megabar
  2. type query
  3. decide I want to use another engine
  4. move hands off of keyboard back to the mouse
  5. click to perform search

Users like myself who relied on the far more sane behavior of the separate search bar can't transfer this knowledge to the megabar (again, one off searches is a LOT more visible - and are actually advertised and labeled as such). New users who are used to tab to complete from unix or Windows shells, or from "tab to search" in Chromium (ironic, no?) can't rely on this either. Instead, tab moves down the search suggestions, instead of doing a Chromium like tab to search, or for doing the very in your face one off search.

It feels obvious to me that megabar makes the existing behavior seem even more bad than it was previously - and I really doubt that a greater percentage of users of other browsers use the tab navigation inside the address bar than those who do so in Firefox. It simply doesn't make sense, and not doing the right thing here with the revamp of megabar just feels broken.

You need to log in before you can comment on or make changes to this bug.