Closed Bug 1577970 Opened 2 years ago Closed 2 years ago

"Search Messages" window's "Move" button is broken (TB 68)

Categories

(Thunderbird :: Search, defect)

defect
Not set
normal

Tracking

(thunderbird_esr6869+ fixed, thunderbird70 fixed)

RESOLVED FIXED
Thunderbird 70.0
Tracking Status
thunderbird_esr68 69+ fixed
thunderbird70 --- fixed

People

(Reporter: mosielski, Assigned: aceman)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image snap.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Thunderbird version 68, after the last update there was a problem in the search engine for letters, earlier after searching for a group of letters you could select these lists and manually holding the mouse to move to any directory, now I can't do the same the Move button at the bottom does not work, the problem is in the letter search engine.

Expected results:

withdrawal of function as in the previous version, manual transfer of mass mailing letters from search engines

Confirmed. Thanks for reporting. We might have to split it into two bugs for the two issues here: Drag & Drop and the Move button.

BTW, using the move button gives this in the error console:
NS_ERROR_ILLEGAL_VALUE: Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIMsgDBView.doCommandWithFolder] folderDisplay.js:1819
doCommandWithFolder chrome://messenger/content/folderDisplay.js:1819
MoveMessageInSearch chrome://messenger/content/SearchDialog.js:541
oncommand chrome://messenger/content/SearchDialog.xul:1

Alice, can you find the regression(s) for us.

Aceman, can you see how we can fix this quickly.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(alice0775)
Flags: needinfo?(acelists)
Keywords: regression
Summary: Problem → Messages can't be moved from "Search Messages" windows via drag and drop any more and the "Move" button is also broken (TB 68)

Jorg K,
What is / How to open the "Search Messages" windows?

Flags: needinfo?(alice0775)

Right click onto a folder, "Search Messages", or Ctrl+Shift+F.

Aceman, since the dragging works from the main window's thread pane (tree), I hope there's just a missing script in the search window's XUL file.

OK, so the first issue was cause in bug 1446609 and should be easy to fix. The second one comes from bug 1558565. Paul, can you take a look if we don't get to it sooner.

Flags: needinfo?(paul)
Regressed by: 1558565, 1446609

On trunk, the move issue move to:
JavaScript error: chrome://messenger/content/folderDisplay.js, line 1822: NS_ERROR_ILLEGAL_VALUE: Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIMsgDBView.doCommandWithFolder]

https://searchfox.org/comm-central/rev/a78b910c726fa294c42e477a343817fd85e232bd/mail/base/content/folderDisplay.js#1822
calling
https://searchfox.org/comm-central/rev/a78b910c726fa294c42e477a343817fd85e232bd/mailnews/base/src/nsMsgDBView.cpp#2406

Hmm, the Move button does display a folder tree, so it's likely caused by
50955fe1cb9823bed5efef3d7b5e5f076e87f0a1 Paul Morris — Bug 1558565 - Refactor the folder-menupopup code; r=mkmelin

I'd guess that not a script is missing but the folder picker is not passing the target folder properly.
Inside MoveMessageInSearch in SearchDialog.js, the file-uri attribute for constructing the target folder is empty.

Actually also the 'id' attribute of the selected folder is empty, which I think we discussed whether to remove it as it may not be unique.
I'll see which other attribute we use to pass the folder URI.

Flags: needinfo?(acelists)

Hey Alice, many thanks, as always!!

Fix the Move button. id an file-uri is not set anywhere so use the item._folder directly as we do in other places.

Interestingly, Seamonkey is not affected, they already get _folder.

I'm not going to fix the drag and drop problem right now, it is not trivial. In bug 1446609 they only removed utilityoverlay.xul from searchDialog.xul but it does not seem as it had something for drag and drop inside. You may want to split it into a new bug.

Assignee: nobody → acelists
Status: NEW → ASSIGNED
Flags: needinfo?(paul)
Attachment #9089616 - Flags: review?(jorgk)

I'm not going to fix the drag and drop problem right now, it is not trivial. In bug 1446609 they only removed utilityoverlay.xul from searchDialog.xul but it does not seem as it had something for drag and drop inside. You may want to split it into a new bug.

Hmm, OK, that removed utilityOverlay.js, but putting this back doesn't help.

OK, filed bug 1577987 for the drag and drop issue.

Summary: Messages can't be moved from "Search Messages" windows via drag and drop any more and the "Move" button is also broken (TB 68) → "Search Messages" window's "Move" button is broken (TB 68)
Comment on attachment 9089616 [details] [diff] [review]
1577970.patch - move button

Works for me, nice to see that rubbish go.
Attachment #9089616 - Flags: review?(jorgk) → review+
Attachment #9089616 - Flags: approval-comm-esr68+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/b345c245522a
pass the selected folder to MoveMessageInSearch() directly instead of the removed 'id' attribute. r=jorgk

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 70.0

Working in 68.1.

You need to log in before you can comment on or make changes to this bug.