Chimera crashed after system requested that it quit prior to restart [@ nsIThread::GetIThread]

VERIFIED DUPLICATE of bug 160241

Status

Camino Graveyard
General
--
critical
VERIFIED DUPLICATE of bug 160241
16 years ago
12 years ago

People

(Reporter: Greg K., Assigned: Simon Fraser)

Tracking

({crash})

unspecified
Camino0.7
PowerPC
Mac OS X
crash

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
using Chimera/20020715, I used Mac OS X's Startup Disk Preferences to select an
OS 9 volume for startup, and clicked "Restart." The system started to shut down
applications, and Chimera then crashed.
(Reporter)

Comment 1

16 years ago
Created attachment 91551 [details]
Crash report generated by Chimera/20020715
(Reporter)

Updated

16 years ago
Keywords: crash

Comment 2

16 years ago
this looks like fun
Assignee: saari → pinkerton
spreading the love around. looks like something in the global history shutdown
code is needed after xpcom has already shut down, so we try to restart it...
Assignee: pinkerton → bryner
I've just run through 3 tries of restarting my computer by picking a new startup
folder with Chimera 20020719 NB or a debug build from today running and it never
crashed.  It's too nice outside to try this a 4th time.  

But if somebody else can see this crash, I bet changing the dealloc method in
CHPreferenceManager to something like "shutdownPrefs", and calling it right
before the [mPreferenceManager release] line in MainController's
applicationWillTerminate method would fix things.
(Reporter)

Comment 5

16 years ago
Created attachment 98589 [details]
Crash report generated by Chimera/2002090913 on 10.1.5 showing crash at nsStrPrivate::EnsureCapacity

This happened to me again last night using Chimera/2002090913 on 10.1.5, but it
generated a completely different stack.
(Reporter)

Comment 6

15 years ago
First stack looks like bug 160241, resolving dup.

Second stack is different. Maybe related to bug 125037?

*** This bug has been marked as a duplicate of 160241 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: Chimera crashed after system requested that it quit prior to restart → Chimera crashed after system requested that it quit prior to restart [@ nsIThread::GetIThread]
(Reporter)

Comment 7

15 years ago
Hm, well, maybe this isn't a dup after all.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 8

15 years ago
It this reproducible? I'm not sure that we handle the 'shutdown' notification.
Assignee: bryner → sfraser
Status: REOPENED → NEW
Target Milestone: --- → Chimera0.7
(Reporter)

Comment 9

15 years ago
I don't think I was able to reproduce it at the time, and it isn't reproducible
now using Chimera/2002120404.
(Reporter)

Comment 10

15 years ago
Has this stack shown up in any TB reports?
(Reporter)

Comment 11

15 years ago
Stack is same as attachment 93362 [details] on bug 160241.

*** This bug has been marked as a duplicate of 160241 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

12 years ago
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsIThread::GetIThread]
You need to log in before you can comment on or make changes to this bug.