Closed Bug 1578027 Opened 2 months ago Closed 2 months ago

Email autocomplete in search doesn't use selected addresses with keyboard

Categories

(Thunderbird :: Search, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1490428

People

(Reporter: liudvikas.akelis, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

I click on the search field in the top right (the one that says Ctrl-K), I type in 'john'. Multiple suggestions appear from my contacts. I navigate to one of them, 'john.smith@gmail.com' using my keyboard direction keys. I press Enter.

Actual results:

Search results appear in a new tab. However, the search was executed for the original string 'john', not for 'john.smith@gmail.com' that was highlighted.

Expected results:

Search should have executed for the highlighted email address, since I navigated to and clicked Enter on it. If I click on one of the suggestions using my mouse, it searches for the suggestion as it should.

Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Component: Untriaged → Search
Resolution: --- → DUPLICATE
Summary: Email autocomplete in search doesn't select with keys → Email autocomplete in search doesn't use selected addresses with keyboard
Duplicate of bug: 1490428
You need to log in before you can comment on or make changes to this bug.