Closed Bug 1578052 Opened 3 months ago Closed 3 months ago

[protection panel] focus indicator/outline on protections toggle nearly invisible because it overlaps the toggle

Categories

(Firefox :: Site Identity, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox70 + verified
firefox71 --- verified

People

(Reporter: asa, Assigned: timhuang)

References

Details

(Keywords: access, Whiteboard: [privacy-panel][skyline][access-p2])

Attachments

(2 files)

In the protections panel accessed from the shield icon in the address bar, the focus indicator/outline for the protections toggle is nearly invisible because it overlaps the toggle. The outline should be outside of the toggle so it's visible.

The same issue exists in the off state of the toggle. The focus outline isn't really an outline so it's difficult to see.

Whiteboard: [skyline] → [privacy-panel][skyline]
Assignee: nobody → tihuang
Status: NEW → ASSIGNED
Priority: -- → P1

We add the focus outline of the TP switch according to different
platforms.

Duplicate of this bug: 1581745
Pushed by tihuang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9fd2cf480008
Add the focus outline of the TP switch in protections panel. r=nhnt11
Whiteboard: [privacy-panel][skyline] → [privacy-panel][skyline][access-p2]
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Tim, can you request uplift on this? :)

Flags: needinfo?(tihuang)

Comment on attachment 9092969 [details]
Bug 1578052 - Add the focus outline of the TP switch in protections panel. r?nhnt11!

Beta/Release Uplift Approval Request

  • User impact if declined: The TP switch in the protections panel won't get a correct focusing effect if a user tabs to it.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. Open any web page
  1. Click the shield icon to open the protections panel.
  2. Press "Tab" several times to focus on the TP switch.
  3. Check whether the focus indicator is correctly applied.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This only changes the CSS. So, it is low risky.
  • String changes made/needed: None
Flags: needinfo?(tihuang)
Attachment #9092969 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9092969 [details]
Bug 1578052 - Add the focus outline of the TP switch in protections panel. r?nhnt11!

Polish fix for the Protections Panel. Approved for 70.0b8.

Attachment #9092969 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]
See Also: → 1582471

This issue is verified as fixed on latest Nightly 71.0a1 and Beta 70.0b9 across platforms: Win 10 x64, macOS 10.13 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.