Closed Bug 1578108 Opened 4 months ago Closed 3 months ago

Can't install temporary addons for VS Code setup

Categories

(DevTools :: General, defect)

70 Branch
defect
Not set

Tracking

(firefox-esr68 unaffected, firefox68 unaffected, firefox69 unaffected, firefox70 verified, firefox71 verified)

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified
firefox71 --- verified

People

(Reporter: hbenl, Assigned: yulia)

References

(Blocks 1 open bug, Regression)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

I tried to debug a WebExtension in VS Code. The VS Code debug adapter for Firefox (which I maintain) wants to install it as a temporary addon via RDP using the AddonsActor, but the AddonsActor seems to be gone. It used to be referenced in the response to a listTabs request, but isn't anymore (in version 70.0b2).

Alex, was this a change related to the Fission refactoring? A first look at Fission bugs I have not seen related work, but maybe you can point me in the right direction.

Flags: needinfo?(poirot.alex)

I instruct Yulia to remove it in bug 1522571 as it wasn't used anywhere within DevTools scope.

This addons actor was only exposing the install temporary addon which only works locally.
It was meant to be used someday by the previous about:debugging, but was never converted to be remote-compatible.

We can revert that if this actor is any important.

Flags: needinfo?(poirot.alex)
Regressed by: 1522571
Status: UNCONFIRMED → NEW
Type: defect → enhancement
Component: Untriaged → General
Ever confirmed: true
Product: Firefox → DevTools
Summary: Can't install temporary addons → Can't install temporary addons for VS Code setup

The AddonsActor is used by the web-ext tool and by the VS Code debug adapter.
web-ext contains a workaround (--pre-install) which installs the extension into the user's profile and I could create the same workaround for the VS Code debug adapter.
However, I am also using this to shut down Firefox via RDP at the end of a VS Code debug session: I install a WebExtension that closes all Tabs and hence stops Firefox. This was necessary because on Windows, I don't have a reference to the Firefox process and this was the only way I found to shut it down. So without the AddonsActor I'd need another way to stop Firefox via the RDP.

I confirm that web-ext run also uses the AddonsActor to install the target extension programmatically on the target Firefox instance (it is used for both the Firefox Desktop and Firefox for Android, on android the target extension is installed temporarily after the extension's xpi file is pushed to the emulator internally by web-ext itself), we do have a --pre-install workaround but it was meant to be used only in older Firefox versions where the AddonsActor wasn't yet available.

The same issue has been filed on the web-ext github repo as:

When this lands, could you request an uplift to beta? The patch landed last week in 70, which went to Beta today.

Assignee: nobody → ystartsev
Status: NEW → ASSIGNED
Type: enhancement → defect
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

hbenl, can you confirm that the fix is working for you?

Flags: needinfo?(hbenl)

I verified that web-ext run -f firefox-nightly was broken before the patch (comment 4), and fixed with the latest version.

  • Broken: Firefox 70.0a1 buildID 20190901214807
  • Fixed: Firefox 71.0a1 buildID 20190902213933

Comment on attachment 9089859 [details]
Bug 1578108 - add addons actor back; r=ochameau

Beta/Release Uplift Approval Request

  • User impact if declined: Users will be unable to debug web extensions using web-ext, and they will not be able to debug web extensions using VSCode
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: You can use any web extension. The one recommended by lgreco is https://github.com/mdn/webextensions-examples/tree/master/beastify
  1. you need to install web-ext https://github.com/mozilla/web-ext by following the instructions there

  2. go to the folder of a web extension for example: https://github.com/mdn/webextensions-examples/tree/master/beastify

  3. in that folder, run web-ext against nightly using web-ext run --firefox-binary /path/to/a/nightly/Firefox ...

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is reintroducing code that was deleted last week
  • String changes made/needed:
Attachment #9089859 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Flags: needinfo?(hbenl)

Yes, it works for me in the latest nightly. Thanks!

QA Whiteboard: [qa-triaged]

Hi, I have retested this issue on Windows 10, Mac OSX 10.14 and Ubuntu 18.04 , This issue is verified as fixed in our latest Nightly build 71.0a1 (2019-09-03).

Comment on attachment 9089859 [details]
Bug 1578108 - add addons actor back; r=ochameau

Fix for web-ext, verified in nightly; let's uplift for beta 4.

Attachment #9089859 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Re-tested this in Firefox Beta 70.0b4 on Windows 10, Mac OsX 10.14 and Ubuntu 18.04 this issue is Verified as fixed in Beta as well.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.