Closed Bug 1578109 Opened 2 years ago Closed 2 years ago

hovering link cause flickering (since the statusbar expands the width of the mail)

Categories

(Thunderbird :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 70.0

People

(Reporter: mkmelin, Assigned: Paenglab)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Another incarnation of bug 1506047. I'd think from bug bug 1577659.

Hover an email with a long url. This will make the status bar over long pushing stuff outside of the screen. Causing you not to hover anymore, since the link moved. Then this loops like crazy.

Khushil, I take the bug as there are some additional clean-ups needed.

Assignee: khushil324 → richard.marti

A crop="end" is needed to let the text cropping. I also changed the crop="right" to crop="end" to be RTL compliant. In the CSS files the statusbarpanel element is no more needed.

Status: NEW → ASSIGNED
Attachment #9089773 - Flags: review?(mkmelin+mozilla)
Attachment #9089773 - Flags: review?(mkmelin+mozilla) → review?(khushil324)
Comment on attachment 9089773 [details] [diff] [review]
1578109-stausText-crop.patch

Review of attachment 9089773 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me, r=khushil.
Comment on attachment 9089773 [details] [diff] [review]
1578109-stausText-crop.patch

You forgot the r+ flag.

Jörg, please change the reviewer in the commit message to r=khushil
Attachment #9089773 - Flags: review?(khushil324) → review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/845b7aa35973
Make the statusText crop long text. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 70.0

Too bad, got landed with wrong reviewer.

Duplicate of this bug: 1508093
You need to log in before you can comment on or make changes to this bug.