Closed Bug 1578148 Opened 2 months ago Closed 2 months ago

Editing message tag colors not functioning correctly in V68

Categories

(Thunderbird :: Folder and Message Lists, defect)

defect
Not set

Tracking

(thunderbird_esr6869+ fixed, thunderbird70 fixed)

VERIFIED FIXED
Thunderbird 70.0
Tracking Status
thunderbird_esr68 69+ fixed
thunderbird70 --- fixed

People

(Reporter: unicorn.consulting, Assigned: jorgk)

References

(Blocks 1 open bug, Regression, )

Details

(Keywords: regression)

Attachments

(1 file, 4 obsolete files)

Editing message colors appears to be broken wit the message "A tag with this name already exists" appearing when you save the color change.

The issue was raised in support, but I can reproduce it in Thunderbird 68 64Bit using the steps to reproduce given in the support topic.

Right click on a message title -> tag -> manage tags
Double click or click on a tag and edit.
Select a new colour and click on the ok

I get the message: 'A tag with that name already exits'

@Wayne. sfhowes mentions in the support thread that the issue is also with 69beta, I can not find anything existing in Bugzilla, or discourse for that matter, so have filed this bug. Please dup if you are aware of anything.

Flags: needinfo?(vseerror)

Thanks for filing, it's the first time I see this issue. BTW, easily confirmed.

And if I edit the name and click OK, nothing happens :-(

Alice, can you find the regression for us. I'm pretty sure this worked when I was working on tag colours in bug 1497041 back in March 2019.

Flags: needinfo?(vseerror) → needinfo?(alice0775)

Sigh, more of bug 1541789 :-(

Regressed by: 1541789

Hey, Alice, thank you so much, that really helps!

Support reference, including workaround:
https://support.mozilla.org/en-US/questions/1267718

Attached patch 1578148-tag-edit.patch (obsolete) — Splinter Review

OK, this fixes the edit. It also fixes "New" when the panel doesn't close.

One issue left: Edit works, but the value in the list isn't updated. Aceman will take over.

Assignee: nobody → jorgk
Attached patch 1578148-tag-edit.patch (v2) (obsolete) — Splinter Review
Attachment #9089899 - Attachment is obsolete: true
Attached patch 1578148-tag-edit.patch (v2b) (obsolete) — Splinter Review
Attachment #9089901 - Attachment is obsolete: true
Attached patch 1578148-tag-edit.patch (obsolete) — Splinter Review

That fixes it. Aceman can review.

Attachment #9089902 - Attachment is obsolete: true

Same patch but with querySelector instead of firstChild.

Attachment #9089903 - Attachment is obsolete: true
Comment on attachment 9089905 [details] [diff] [review]
1578148-tag-edit.patch (v3b)

Review of attachment 9089905 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you, this works nicely now.
Attachment #9089905 - Flags: review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/86e0e08f619f
Fix various problems in tag add/edit. r=aceman DONTBUILD

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Comment on attachment 9089905 [details] [diff] [review]
1578148-tag-edit.patch (v3b)

We'll fix this for TB 68.1.
Attachment #9089905 - Flags: approval-comm-esr68+
Target Milestone: --- → Thunderbird 70.0

Working in 68.1.

Status: RESOLVED → VERIFIED
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/37dcd837fe67
Follow-up: No need to pass 'event' explicitly. r=me
Duplicate of this bug: 1578588
Duplicate of this bug: 1580452
You need to log in before you can comment on or make changes to this bug.