Closed Bug 1578196 Opened Last month Closed Last month

TB68: Invite attendee does not trigger reading freebusy information from calendar

Categories

(Calendar :: General, defect)

Lightning 7.0
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: d.spitznagel, Assigned: darktrojan)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0

Steps to reproduce:

  1. Open calendar tab and double click into any calendar (doesn't matter if local or caldav).
  2. Press "invite Attendees".

Actual results:

The Invite Attendees window pops up but does NOT read freebusy information.
The timeline bar shows "no information".
I need to click "next slot" or "zoom in" or "zoom out" to make freebusy information appear.

Expected results:

When "Invite Attendees" window pops up it should read freebusy information without any action needed.
In TB 60.8.0 this works as expected... the timeline bar shows free, tentative, etc. upon clicking "Invite Attendees" immediately.

Component: Untriaged → General
Flags: needinfo?(paul)
Flags: needinfo?(geoff)
Keywords: regression
Product: Thunderbird → Calendar
Version: 68 → Lightning 7.0

This dialog must be a contender for worst UI in Thunderbird.

Assignee: nobody → geoff
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(paul)
Flags: needinfo?(geoff)
Attachment #9090268 - Flags: review?(paul)
Comment on attachment 9090268 [details] [diff] [review]
1578196-attendees-freebusy-1.diff

Can you please add the uplift request, since I won't be able to watch everything.
Attachment #9090268 - Flags: approval-calendar-esr?(paul)
Attachment #9090268 - Flags: approval-calendar-beta?(paul)

The code changes look good. No try run yet. I'm working on getting my esr68 build up and running (since I'll need that anyway for more bug fix testing and for porting prettier changes). Then I can test and start a try run.

Comment on attachment 9090268 [details] [diff] [review]
1578196-attendees-freebusy-1.diff

Review of attachment 9090268 [details] [diff] [review]:
-----------------------------------------------------------------

r=pmorris  
I did a try run just to confirm that nothing else broke.  Looks fine.
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=c76b0627f859ad7d6e91237e3030120d4e2a7a27

When testing the patch I do see the free/busy information upon opening the dialog (and not the pink bar indicating no information).
Attachment #9090268 - Flags: review?(paul)
Attachment #9090268 - Flags: review+
Attachment #9090268 - Flags: approval-calendar-esr?(paul)
Attachment #9090268 - Flags: approval-calendar-esr+
Attachment #9090268 - Flags: approval-calendar-beta?(paul)
Attachment #9090268 - Flags: approval-calendar-beta+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/5f3bd0c1707d
In attendees dialog, free/busy information should load on opening. r=pmorris

Status: ASSIGNED → RESOLVED
Closed: Last month
Keywords: checkin-needed
Resolution: --- → FIXED

I can confirm that this is fixed with TB from here...
32bit: https://queue.taskcluster.net/v1/task/b1ItT68HT0uJA9jkhbd7Eg/runs/0/artifacts/public/build/install/sea/target.installer.exe

But Geoff Lankow is right saying. "This dialog must be a contender for worst UI in Thunderbird.".
Now that this works I discovered other bad things in this dialog.
Should I open a new bug report or answer here, Jorg K?

New bug please, CC Geoff and me.

You need to log in before you can comment on or make changes to this bug.