Closed Bug 1578217 Opened 1 year ago Closed 1 year ago

Remove sync "yellow state" telemetry

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 - unaffected
firefox71 + verified

People

(Reporter: RaulG, Assigned: markh)

References

(Regression)

Details

Attachments

(1 file)

[Tracking Requested - why for this release]:

Version increase simulation: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&revision=b8832c913b1c7150d74456e803a49ebe41d376f2&selectedJob=264546345

Log link: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=264546345&repo=try&lineNumber=2482

Log snippet:
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - TEST-PASS | services/sync/tests/unit/test_browserid_identity.js | test_initialialize - [test_initialialize : 218] "assertion" == "assertion"
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - PID 14639 | 1567424072469 Sync.BrowserIDManager TRACE Successfully got a token
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - PID 14639 | 1567424072471 Sync.BulkKeyBundle INFO BulkKeyBundle being created for undefined
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - PID 14639 | 1567424072472 Sync.Status DEBUG Status.login: error.login.reason.no_username => success.login
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - PID 14639 | 1567424072472 Sync.Status DEBUG Status.service: service.client_not_configured => success.status_ok
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - TEST-PASS | services/sync/tests/unit/test_browserid_identity.js | test_initialialize - [test_initialialize : 90] true == true
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - TEST-PASS | services/sync/tests/unit/test_browserid_identity.js | test_initialialize - [test_initialialize : 91] true == true
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - PID 14639 | JavaScript strict warning: resource://testing-common/services/sync/utils.js, line 316: ReferenceError: reference to undefined property "services.sync.sync_login_state_transitions"
[task 2019-09-02T11:34:33.114Z] 11:34:33 WARNING - TEST-UNEXPECTED-FAIL | services/sync/tests/unit/test_browserid_identity.js | test_initialialize - [test_initialialize : 92] "undefined" deepEqual {"SUCCESS":1}
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - /builds/worker/workspace/build/tests/xpcshell/tests/services/sync/tests/unit/test_browserid_identity.js:test_initialialize:92
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - exiting test
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - Unexpected exception NS_ERROR_ABORT:
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - _abort_failed_test@/builds/worker/workspace/build/tests/xpcshell/head.js:789:20
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - do_report_result@/builds/worker/workspace/build/tests/xpcshell/head.js:890:5
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - Assert<@/builds/worker/workspace/build/tests/xpcshell/head.js:67:21
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - proto.report@resource://testing-common/Assert.jsm:233:10
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - deepEqual@resource://testing-common/Assert.jsm:310:8
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - test_initialialize@/builds/worker/workspace/build/tests/xpcshell/tests/services/sync/tests/unit/test_browserid_identity.js:92:10
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - async*run_next_test/_run_next_test/<@/builds/worker/workspace/build/tests/xpcshell/head.js:1565:22
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - _run_next_test@/builds/worker/workspace/build/tests/xpcshell/head.js:1565:38
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - run@/builds/worker/workspace/build/tests/xpcshell/head.js:733:9
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - _do_main@/builds/worker/workspace/build/tests/xpcshell/head.js:246:6
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - _execute_test@/builds/worker/workspace/build/tests/xpcshell/head.js:573:5
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - @-e:1:1
[task 2019-09-02T11:34:33.114Z] 11:34:33 INFO - exiting test
[task 2019-09-02T11:34:33.115Z] 11:34:33 INFO - "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "ReferenceError: reference to undefined property "services.sync.sync_login_state_transitions"" {file: "resource://testing-common/services/sync/utils.js" line: 316}]"
[task 2019-09-02T11:34:33.115Z] 11:34:33 INFO - PID 14639 | 1567424072488 Sync.SyncScheduler TRACE Handling network:offline-status-changed

Leif, see bug 1523644 comment 6 ;) In that bug we extended to 72 - what about now? Delete or extend?

Flags: needinfo?(loines)

OK, I think we can delete this now since the new FxA toolbar icon events include whether a user is unverified.

Flags: needinfo?(loines)

Thom reviewed the addition of this, so I guess he gets the short-straw for rubber-stamping the removal!

Assignee: nobody → markh
Status: NEW → ASSIGNED
Depends on: 1375635
Summary: Perma test_browserid_identity.js | test_initialialize - [test_initialialize : 92] "undefined" deepEqual {"SUCCESS":1} when Gecko version increases to 72 on 2019-10-21 → Remove sync "yellow state" telemetry
Attachment #9092522 - Attachment description: Bug 1578217 - remote the sync 'yellow states' telemetry. r?tcsc → Bug 1578217 - remove the sync 'yellow state' telemetry. r?tcsc
Pushed by mhammond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9d31a1c17ef8
remove the sync 'yellow state' telemetry. r=tcsc
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Flags: needinfo?(markh)
You need to log in before you can comment on or make changes to this bug.