Closed Bug 1578236 Opened 1 year ago Closed 1 year ago

The "CFR Sync Logins" recommendation disappears after switching tabs

Categories

(Firefox :: Messaging System, defect, P1)

70 Branch
Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 71
Iteration:
71.1 - Sept 2 - 15
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 + verified
firefox71 --- verified

People

(Reporter: cosmin.muntean, Assigned: andreio)

References

Details

(Whiteboard: [skyline])

Attachments

(3 files)

[Notes]:

  • This issue is also reproducible in the following scenarios:
    • When opening a new tab and switch back to the tab where the recommendation was triggered.
    • When navigating to another website in the same tab and click the browser's "Back" button.

[Affected Versions]:

  • Nightly 71.0a1
  • Beta 70.0b3

[Affected Platforms]

  • All Windows
  • All Mac
  • All Linux

[Prerequisites]:

  • Have a new Firefox profile.
  • Have set the browser.newtabpage.activity-stream.asrouter.providers.cfr pref to {"id":"cfr","enabled":true,"type":"local","localProvider":"CFRMessageProvider","bucket":"cfr","frequency":{"custom":[{"period":"daily","cap":1}]},"categories":["cfrAddons","cfrFeatures"],"updateCycleInMs":3600000}
  • Have no passwords saved.
  • You are NOT sync to FxA.

[Steps to reproduce]:

  1. Open the latest Nightly browser with the profile from prerequisites and open a few tabs.
  2. In a new tab navigate to a login page of a website (eg: https://twitter.com/login).
  3. Complete the username and password fields with valid credentials.
  4. Click the "Login" button and click the "Save" button from the "Save password" doorhanger.
  5. Focus another tab, then focus back the tab where the recommendation was triggered.
  6. Observe the addressbar.

[Expected results]:

  • The "CFR Sync Logins" recommendation button is displayed.

[Actual results]:

  • The "CFR Sync Logins" recommendation button is no longer displayed

[Additional Notes]:

  • This issue is not reproducible with "CFR Pin tabs".
  • Attached a screen recording with the issues.
Assignee: nobody → andrei.br92
Iteration: --- → 71.1 - Sept 2 - 15
Priority: -- → P1

All CFR messages are tied to a certain browser tab. We show a targeted message for a website and switching to a different tab (we simplify and assume this a different website) should clear that message because it's not relevant.
My intuition here is to keep this particular CFR message around regardless of tab because it offers a browser feature and it's not connected to a specific website.
Edit: Also the behavior should be controlled through message configuration.

Flags: needinfo?(abenson)

We want to quickly fix this by matching the behavior of our other CFRs and we can then work on separate dismiss strategies in a follow up bug.

Flags: needinfo?(abenson)
Summary: The "CRF Sync Logins" recommendation disappears after switching tabs → The "CFR Sync Logins" recommendation disappears after switching tabs
Duplicate of this bug: 1578209

[Tracking Requested - why for this release]: CFR messages gets dismissed unintentionally if the user navigates away without interacting with it.

Pushed by pdahiya@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/51eed6df0a9d
Add back the CFR message after navigating between tabs when a host is not defined r=pdahiya
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

I have verified this issue and is no longer reproducible on the latest Nightly 71.0a1 (2019-09-08) build on Windows 7 x64, Mac 10.14 and Arch Linux 4.14.
The "CFR Sync Logins" recommendation button remains displayed in the following cases:

  • After switching tabs.
  • After opening a new tab.
  • After opening a new window.
  • After navigating to another website in the same tab.
Status: RESOLVED → VERIFIED

Comment on attachment 9090659 [details]
Bug 1578236 - Add back the CFR message after navigating between tabs when a host is not defined

Beta/Release Uplift Approval Request

  • User impact if declined: User experience is affected for Lockwise/Password sync CFR messages
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): landed in nightly, verified by QA
  • String changes made/needed: n/a
Attachment #9090659 - Flags: approval-mozilla-beta?

Comment on attachment 9090659 [details]
Bug 1578236 - Add back the CFR message after navigating between tabs when a host is not defined

Fix for Skyline feature, includes new tests, verified in nightly.
OK for uplift for beta 6.

Attachment #9090659 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

I have verified this issue and is no longer reproducible on the latest FIrefox Beta 70.0b6 build on Windows 10 x64, Windows 7 x64, Mac 10.14 and Arch Linux 4.14.

You need to log in before you can comment on or make changes to this bug.