Closed Bug 1578257 Opened 10 months ago Closed 5 months ago

The content and the elements from the “Special Monitor Snippet” are wrongly resized at 1134px and 1135px width

Categories

(Firefox :: Messaging System, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 74
Tracking Status
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- wontfix
firefox74 --- verified

People

(Reporter: acupsa, Assigned: emcminn)

References

Details

Attachments

(2 files)

Attached image rendering issue.png

[Affected versions]:

  • Firefox Nightly 71.0a1, Build ID: 20190902094857

[Affected Platforms]:

  • All Windows
  • All Mac
  • All Linux

[Prerequisites]:

  • Have a new Firefox profile with the browser.newtabpage.activity-stream.asrouter.devtoolsEnabled pref's value set to true.

[Steps to reproduce]:

  1. Open the browser with the profile from the prerequisites.
  2. Navigate to "about:newtab#asrouter" and select the "snippets_local_testing" option from the "Messages" dropdown menu.
  3. Scroll to the bottom of the page and click the "Show" button from the "SPECIAL_SNIPPET_MONITOR" section.
  4. Click the "Collapse devtools" button from the top-right part of the page.
  5. Resize the browser to the width of 1134 or 1135px.
  6. Observe the "Special Monitor" snippet's elements.

[Expected result]:

  • All the snippet's elements are correctly rendered and visible.

[Actual result]:

  • The “Special Monitor” snippet card is narrower than the “Search” bar and the “Dismiss” button is displayed under the search bar.

[Notes]:

  • Attached a screenshot of the issue.
Priority: -- → P2
Assignee: nobody → emcminn
Pushed by aoprea@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fcbbd601e982
Positioning fixes for the Special Monitor Snippet r=andreio
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 74

I have verified that the issue is no longer reproducible on Firefox Nightly 74.0a1 Build ID 20200205055433 using Win 10, Linux Ubuntu 16.04 and Mac 10.14.
"Special Monitor" snippet is correctly rendered for any page width.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.