Closed Bug 1578304 Opened 11 months ago Closed 10 months ago

Tab title does not update after opening an Adobe Flash based url

Categories

(Core :: DOM: Content Processes, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- wontfix
firefox70 --- verified
firefox71 --- verified

People

(Reporter: itiel_yn8, Assigned: barret)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

STR:

  1. Open any website (not a new tab)
  2. In the same tab navigate to http://www.bubbleshooter.net/games/001_bubble_shooter.swf

AR:
Tab titles does not update and is stuck on the previous page's title.

ER:
Tab title updates to the new title, in this case the entire url itself.

Note that this is working as expected when navigating from a new tab to the mentioned url.

Bug 1510569 - Port Content:LoadURIResult message to IPDL r=mconley

The WebProgress#sendLoadCallResult method only existed to send a empty async
message and was only called from the WebNavigationChild. Since
WebNavigationChild is in the process of being removed, it makes sense to
inline the replaced method into its call site.

Differential Revision: https://phabricator.services.mozilla.com/D34566

2019-09-03T23:26:17: DEBUG : Did not find a branch, checking all integration branches
2019-09-03T23:26:17: INFO : The bisection is done.
2019-09-03T23:26:17: INFO : Stopped

Regressed by: 1510569
Component: Tabbed Browser → DOM: Content Processes
Product: Firefox → Core
Flags: needinfo?(mconley)

Hey barret, this looks like a regression from bug 1510569 - any idea what's going on here?

Flags: needinfo?(mconley) → needinfo?(brennie)

I looked at the patch again and nothing jumps out at me but I can take a look once I'm back next week.

Flags: needinfo?(brennie)

The priority flag is not set for this bug.
:jimm, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jmathies)
Flags: needinfo?(brennie)
Assignee: nobody → brennie
Flags: needinfo?(brennie)

I've actually managed to track this down to this earlier revision (still by me).

I believe I've narrowed this down to being caused by plugin documents not having a docshell and therefore we bail out early in BrowserChild::OnLocationChange and forward the event to the parent.

Edit: I was correct about the revision that caused this issue but incorrect about the underlying issue. The tab title is actually derived from elsewhere (a DOMTitleChanged message sent to the parent process and caught in the <browser>).

Pushed by brennie@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2c0229c483d8
Correctly set content title from onLocationChange event r=Ehsan

This should be backported to beta if possible.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

(In reply to :ehsan akhgari from comment #8)

This should be backported to beta if possible.

Flags: needinfo?(jmathies) → needinfo?(brennie)
Priority: -- → P1

Comment on attachment 9099345 [details]
Bug 1578304 - Correctly set content title from onLocationChange event r?Ehsan

Beta/Release Uplift Approval Request

  • User impact if declined: A user could be fooled by navigating to a SWF URL where the titlebar remains the same as the previous page. This is unlikely, however, as we currently prompt to enable flash on SWF objects.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This change is not risky because it only affects tab titles in a very specific case (when visiting SWF urls after visiting a page besides about:newtab/about:blank first).
  • String changes made/needed:
Flags: needinfo?(brennie)
Attachment #9099345 - Flags: approval-mozilla-beta?

Fixed on latest Nightly.

Status: RESOLVED → VERIFIED

Comment on attachment 9099345 [details]
Bug 1578304 - Correctly set content title from onLocationChange event r?Ehsan

Fix for recent regression, let's go for it in beta 14.

Attachment #9099345 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

itiel, can you verify that this works for you now in nightly?

Flags: needinfo?(itiel_yn8)

(In reply to Liz Henry (:lizzard) from comment #14)

itiel, can you verify that this works for you now in nightly?

Well, I kinda did already, in comment 12 :)

Flags: needinfo?(itiel_yn8)

Oh, perfect, I missed that the first time around. Thanks.

Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Reproduced the initial issue using an old Beta build: 20191007220302
Verified - fixed on latest Beta 70.0b14 (64-bit) (Build id: 20191010142853) on Windows 10, Mac OS 10.14 and Ubuntu 18.04.

QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.