Closed Bug 1578305 Opened 2 years ago Closed 2 years ago

If layers.acceleration.draw-fps is set to true, we crash when closing windows

Categories

(Core :: Graphics: Layers, defect)

All
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- fixed

People

(Reporter: mstange, Assigned: mstange)

References

(Regression)

Details

(Keywords: regression)

Crash Data

Attachments

(1 file)

I made a mistake in the patch for bug 1578100 and it's tripping the assertion in ~NativeLayerRootCA that checks whether all sublayers have been removed.

Pushed by mstange@themasta.com:
https://hg.mozilla.org/integration/autoland/rev/8fd42fa36f32
Remove debug overlay layers in LayerManagerComposite::Destroy(). r=mattwoodrow
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Duplicate of this bug: 1578443
Crash Signature: [@ mozilla::layers::NativeLayerRootCA::~NativeLayerRootCA]
You need to log in before you can comment on or make changes to this bug.