Closed Bug 1578454 Opened 2 months ago Closed Last month

FF69 limits the maximum zoom level in Reader Mode

Categories

(Toolkit :: Reader Mode, defect, P1)

69 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
relnote-firefox --- 69+
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- verified
firefox70 --- verified
firefox71 --- verified

People

(Reporter: imthepipe, Assigned: Gijs)

References

(Regression)

Details

(Keywords: access, regression)

Attachments

(6 files)

Attached image FF Reader Mode Zoom.jpg

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

Enter Reader Mode
Press Control +

Actual results:

Zoom level did not increase beyond a certain point

Expected results:

It seems that prior to FF 69, zoom levels were much greater - in reader mode, anyway. I used to be able to zoom 8 levels to at least 300%. But with FF 69, I can only zoom 4 levels - 150%. In non-reader mode, I can still zoom 8 levels, so this tells me Reader Mode must have been changed. As someone with low vision (macular degeneration), this hinders my ability to easily read content. Please increase the maximum zoom level to where it was prior to FF 69.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Reader Mode
Product: Firefox → Toolkit

(In reply to [:philipp] from comment #2)

can we increase https://searchfox.org/mozilla-central/source/toolkit/components/reader/AboutReader.jsm#236 ?

I don't see why not.

Assignee: nobody → gijskruitbosch+bugs
Type: enhancement → defect
Keywords: access
Priority: -- → P1
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/0864ac97b84c
increase max font size in reader mode to match 300% zoom on default font size, r=jaws
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

Comment on attachment 9091455 [details]
Bug 1578454 - increase max font size in reader mode to match 300% zoom on default font size, r?jaws

Beta/Release Uplift Approval Request

  • User impact if declined: Limited usability of reader mode for users with low vision
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: n/a
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This simply increases a maximum constant to allow greater zooming
  • String changes made/needed: n/a
Attachment #9091455 - Flags: approval-mozilla-beta?

Comment on attachment 9091455 [details]
Bug 1578454 - increase max font size in reader mode to match 300% zoom on default font size, r?jaws

Allow greater font size, good for a11y.
OK for uplift for beta 6.

Attachment #9091455 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Duplicate of this bug: 1579514
QA Whiteboard: [qa-triaged]

Verified as fixed on the latest Nightly 71.0a1 (Build ID: 20190913092859) and Firefox 70 beta 6 - tested on Windows 10 x64-bit, Ubuntu 18.04 and Mac OS X 10.13.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Comment on attachment 9091455 [details]
Bug 1578454 - increase max font size in reader mode to match 300% zoom on default font size, r?jaws

Beta/Release Uplift Approval Request

  • User impact if declined: Limited usability of reader mode for users with low vision
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: n/a
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This simply increases a maximum constant to allow greater zooming
  • String changes made/needed: none
Attachment #9091455 - Flags: approval-mozilla-release?

Comment on attachment 9091455 [details]
Bug 1578454 - increase max font size in reader mode to match 300% zoom on default font size, r?jaws

Fixes a regression in Reader Mode causing fonts to not be as zoomable as expected. Approved for 69.0.1.

Attachment #9091455 - Flags: approval-mozilla-release? → approval-mozilla-release+

Added to the 69.0.1 relnotes:

Fixed the maximum size of fonts in Reader Mode when zoomed

Verified as fixed on Firefox 69.0.1 - tested on Windows 10 x64-bit, Ubuntu 18.04 and Mac OS X 10.14.

The reader mode fix implemented in FF 69.0.1 is an improvement, but doesn't completely address the issues.

The main issue is that the maximum zoom in reader mode prior to version 69 was much greater than FF 69 or the "fixed" FF 69.0.1. Maximum zoom in reader mode was increased with the fix applied to FF 69.0.1, but it is still not what it was prior to FF69. I don't know how the values increase (e.g.: fixed pixel amount. percentage, etc.), but I do know that prior to FF 69. when I switched to reader mode, I would tap Ctrl+ 10 times to get to a zoom level I could read comfortably - yes, my vision is horrible. The maximum zoom levels in FF69 and FF 69.0.1 were/are insufficient. I have screenshots to show the difference, but for the life of me can't see (no pun intended) how to attach/upload them.

For now, the work around I'm using is a bookmarklet created by another user who commented on this. Apologies - can't find his name at the moment, but the bookmarklet contains the javascript code noted below. I simply changed the pixel size to 127. In addition to being a practical workaround, it's actually easier to use because I only have to click twice instead of clicking once, then tapping Ctrl+ 10 to 20 times.

javascript:void(document.querySelector('div.container').style.fontSize='127px');

Another related issue is that the zoom level shown in the FF menu while in reader mode is inaccurate. It doesn't change when zooming, nor does it display the correct zoom level after zooming. In normal mode, it works fine

(In reply to imthepipe from comment #17)

I have screenshots to show the difference, but for the life of me can't see (no pun intended) how to attach/upload them.

You can upload files here: https://bugzilla.mozilla.org/attachment.cgi?bugid=1578454&action=enter
You'll have to use the form more than once for multiple screenshots.

But it sounds like you used a combination of full page zoom and altering the reader mode font size, in Firefox 68 and earlier. We changed reader mode so now, zoom shortcuts no longer use full page zoom on reader mode and only change the font size. This was felt to be an advantage because this way, the reader mode UI does not change, only the content - just like for other pages, the browser UI does not zoom, only the content. There isn't another practical way to achieve that effect without "rerouting" what the page zoom shortcuts do.

For now, the work around I'm using is a bookmarklet created by another user who commented on this. Apologies - can't find his name at the moment, but the bookmarklet contains the javascript code noted below. I simply changed the pixel size to 127. In addition to being a practical workaround, it's actually easier to use because I only have to click twice instead of clicking once, then tapping Ctrl+ 10 to 20 times.

javascript:void(document.querySelector('div.container').style.fontSize='127px');

I'm a little surprised here, because the changed font size should now be persisted - that is, once you've increased the font size / zoom level, it should stay zoomed in anyway, and the same font size / zoom level should apply on other things you view in reader mode. Whereas presumably you're executing this bit of JS every time you open reader mode...

Another related issue is that the zoom level shown in the FF menu while in reader mode is inaccurate. It doesn't change when zooming, nor does it display the correct zoom level after zooming.

Right, because the zoom indicators are based on full page zoom, which in fact is not changing while you're using the shortcuts (or any of the other UI entrypoints, for that matter).

What do the indicators tell you for reader mode if you always have it zoomed in, though? That is, does this really matter, or was it just an observation that you hoped was helpful? (That's fine, just trying to make sure I'm not missing something else.) :-)

Flags: needinfo?(imthepipe)
Flags: needinfo?(imthepipe)

Is there any reason not to let FONT_MAX_SIZE be absurdly large? Currently it effectively caps the value of reader.font_size at 24 --

https://dxr.mozilla.org/mozilla-central/source/toolkit/components/reader/AboutReader.jsm#236

-- which yields a base font-size of 58px (10 + (2 * 24)), which is approximately 300% the starting size of 20px at level 5.

Some users require a larger size. Using a max size of 60 would let users get up to 130px.

Regarding larger size and using a max size of 60 - is this something I can configure in about:config? I see a setting for reader.font_size. It is currently set to a value of 5. If I want a font size of 130px, is this what needs to change to 60?

(In reply to jscher2000 from comment #22)

Is there any reason not to let FONT_MAX_SIZE be absurdly large?

Usability / confusion for people who do not need such a large font size (ie using modifier + scroll or modifier + +/- and holding it down should do something not completely unhelpful for those users). I'm not aware of any other reasons.

(In reply to imthepipe from comment #23)

Regarding larger size and using a max size of 60 - is this something I can configure in about:config?
You can configure the font size, but the maximum of 24 is currently hardcoded.

I see a setting for reader.font_size. It is currently set to a value of 5.

This is pretty confusing - is this on 68? On 69 I'd expect it to be 24 if you'd maxed out trying to zoom the page with ctrl-+ . If we're not saving that correctly that's probably a different bug. Can you clarify where/when you see this being 5 ?

If I want a font size of 130px, is this what needs to change to 60?

Yes, but it'll automatically get normalized to something within the listed bounds, ie I don't think changing it to 60 will do much for you.

Flags: needinfo?(imthepipe)

Here's where I'm seeing the 5 value relative to the reader font size.

Flags: needinfo?(imthepipe)
Attached image reader.font_size.jpg

Regarding altering the reader mode font size, in Firefox 68 and earlier - I did not. Had no need to since it worked fine as it was.

Is there any plan to increase the reader mode font size to achieve the same level of accessibility as before the change that stops reader mode and zoom working in conjunction? As imthepipe says, the fix in 69.0.1 is an improvement, but Firefox is still less accessible than it was before. I'm visually impaired and can no longer read with the current release

(In reply to ciarantreacy1 from comment #28)

Is there any plan to increase the reader mode font size

I'm struggling to understand the comments here, to be honest. I'm happy to increase the maximum here some more. What I'm struggling with is figuring out what the "right" maximum is so that we don't have to keep changing it. To do that, I'm trying to work out what people were doing in 68 and what the outcome was, so that we can achieve the same outcome here - the change I landed for 69.0.1 was attempting to do exactly that, but clearly something is different. The screenshot in comment #26 has just confused me further...

(In reply to :Gijs (he/him) from comment #24)

(In reply to imthepipe from comment #23)

I see a setting for reader.font_size. It is currently set to a value of 5.

This is pretty confusing - is this on 68? On 69 I'd expect it to be 24 if you'd maxed out trying to zoom the page with ctrl-+ . If we're not saving that correctly that's probably a different bug. Can you clarify where/when you see this being 5 ?

imthepipe, what version of Firefox did you take the screenshot on? And, in 68 when you zoom to what you consider a comfortable level, can you tell me the following values:

  • the zoom level displayed in the address bar
  • the reader mode font size pref you showed from about:config
  • the computed font size in the devtools inspector

Thank you!

Flags: needinfo?(imthepipe)

• The screenshots were from FF 69.0.1.
• In FF 68, I don't recall what the exact zoom level was - only that I pressed Ctrl+ at least 8 times to get to a comfortable level
• The reader mode font size pref you showed from about:config - not sure what font size this was
• The computed font size in the devtools inspector - for what? The max zoom in FF 68? If so, I don't have FF 68 installed any longer.

Sorry I can't provide more details. Happy to provide any info I can though.

Flags: needinfo?(imthepipe)

(In reply to :Gijs (he/him) from comment #29)

I'm struggling to understand the comments here, to be honest. I'm happy to increase the maximum here some more. What I'm struggling with is figuring out what the "right" maximum is so that we don't have to keep changing it. To do that, I'm trying to work out what people were doing in 68 and what the outcome was, so that we can achieve the same outcome here

Thanks Gijs. Sorry for the confusion. In Firefox 68 I had the reader font set to its maximum using the font adjuster on the left side panel. I would then press ctrl + to zoom to the maximum 300%. I'm not sure what the resulting font size was in pt, but it was bigger than the fix in 69.0.1 allows

Blocks: 1583837
You need to log in before you can comment on or make changes to this bug.