Closed Bug 1578576 (angle-72) Opened 10 months ago Closed 8 months ago

Update ANGLE in Firefox 72

Categories

(Core :: Graphics, enhancement, P1)

71 Branch
enhancement

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox71 --- wontfix
firefox72 --- fixed

People

(Reporter: miko, Assigned: miko)

References

(Blocks 1 open bug)

Details

(Keywords: perf-alert)

Attachments

(4 files, 5 obsolete files)

The target ANGLE version is 3865.

Depends on D44561

Depends on D44568

Depends on D44569

Depends on D44570

Attachment #9090229 - Attachment is obsolete: true
Attachment #9090228 - Attachment is obsolete: true
Attachment #9090227 - Attachment is obsolete: true
Attachment #9090226 - Attachment is obsolete: true

Depends on D44561

Depends on D44579

Depends on D44580

Attachment #9090243 - Attachment is obsolete: true
Attachment #9090244 - Attachment description: Bug 1578576 - Part 4: Prefer ES2 for WebGL1 r=jgilbert → Bug 1578576 - Part 3: Prefer ES2 for WebGL1 r=jgilbert
Attachment #9090245 - Attachment description: Bug 1578576 - Part 5: Update webgl-conf expectations r=jgilbert → Bug 1578576 - Part 4: Update webgl-conf expectations r=jgilbert
Pushed by mikokm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/3064469c073d
Part 1: Update angle updater and merge base r=jgilbert
https://hg.mozilla.org/integration/autoland/rev/13282d7a47a5
Part 2: Update to ANGLE 3865 r=jgilbert
https://hg.mozilla.org/integration/autoland/rev/cd2799d2d190
Part 3: Prefer ES2 for WebGL1 r=jgilbert
https://hg.mozilla.org/integration/autoland/rev/e5b3436fc277
Part 4: Update webgl-conf expectations r=jgilbert
Regressions: 1579743
Regressions: 1579910

Backed out 4 changesets (bug 1578576) for causing build failure with microsoft visual studio 2019. a=backout

Backout:
https://hg.mozilla.org/mozilla-central/rev/265d683ed5c396f3f0e38044cd2a91f881d931b7

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla71 → ---
Flags: needinfo?(mikokm)

As this was already backed out not logging a separate bug:

This also caused a performance regression:

== Change summary for alert #23001 (as of Mon, 09 Sep 2019 01:32:06 GMT) ==

Regressions:

20% tp5o_scroll windows10-64-shippable-qr opt e10s stylo 1.75 -> 2.10
18% tart windows10-64-shippable-qr opt e10s stylo 2.35 -> 2.76
6% tscrollx windows10-64-shippable-qr opt e10s stylo 0.85 -> 0.90

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=23001

There are some r+ patches which didn't land and no activity in this bug for 2 weeks.
:miko, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(mikokm)

This cannot be landed yet because of the talos regressions mentioned in comment 13.

Flags: needinfo?(mikokm)
Blocks: 1212878

Yeah, sounds like we fell off of a fast-path. Do you have bandwidth to look into it, miko?

Flags: needinfo?(mikokm)

gw: Any suspicions?

Flags: needinfo?(gwatson)
Summary: Update ANGLE in Firefox 71 → Update ANGLE in Firefox 72

We discussed this briefly in Slack. The possible ideas we came up with were:

  1. dual source blending patches.
  2. parallel / cache shader issues.
  3. y-flip framebuffer extension.
Flags: needinfo?(gwatson)

(In reply to Jeff Gilbert [:jgilbert] from comment #16)

Yeah, sounds like we fell off of a fast-path. Do you have bandwidth to look into it, miko?

I will try to track down where the regressions came from.

Flags: needinfo?(mikokm)
Depends on: 1594436
Pushed by mikokm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/77cee77c0307
Part 1: Update angle updater and merge base r=jgilbert
https://hg.mozilla.org/integration/autoland/rev/3a91885d47e0
Part 2: Update to ANGLE 3865 r=jgilbert
https://hg.mozilla.org/integration/autoland/rev/3a527c210483
Part 3: Prefer ES2 for WebGL1 r=jgilbert
https://hg.mozilla.org/integration/autoland/rev/3e32f97460b0
Part 4: Update webgl-conf expectations r=jgilbert
Alias: angle-72
Regressions: 1601703

If mozregression is correct, this merge caused the regression described in Bug 1608933.

Regressions: 1608933

Trying to pare down our cherry-picks:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=30725eeef6066f5943c9d33b7a65a4b18d1c2040

"Do not override symbol visibility attribute on non-windows builds"
Upstreaming: https://chromium-review.googlesource.com/c/angle/angle/+/2029513

"Remove static_assert for global mutex"
Seems to not be needed anymore.

" Disable debug layers"
Seeeems to just change the behavior of the win+debug generated/test_2_conformance2__extensions__ovr_multiview2_draw_buffers.html test to failure. We can just mark this failure change as expected.

"Fix MinGW include"
Already fixed upstream.

You need to log in before you can comment on or make changes to this bug.