Closed Bug 1578624 Opened 1 year ago Closed 5 months ago

Use BrowsingContext::LoadURI for frontend document loads

Categories

(Core :: DOM: Core & HTML, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla71
Fission Milestone M4
Tracking Status
firefox71 --- fixed

People

(Reporter: mattwoodrow, Assigned: mattwoodrow)

References

(Blocks 1 open bug)

Details

Attachments

(11 files, 1 obsolete file)

47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review

I want to try getting parent-process loads to be initiated in the parent process using DocumentChannelParent directly (and then we can connect them to the right content process once we have a response).

The first step for that is getting some loads to be triggered through the BrowsingContext, and then we can intercept it there.

Priority: -- → P2
Blocks: 1586129
Pushed by jyavenard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/818bc6e20c7d
P1: Serialize SubstitutingURL fully. r=mayhemer
https://hg.mozilla.org/integration/autoland/rev/1d762fdce921
P2: Extend nsDocShellLoadState for the extra options needed to describe front end loads. r=kmag,nika
https://hg.mozilla.org/integration/autoland/rev/6c02bbe5c1c5
P3: Move conversion from LoadURIOptions processing into a static constructor for nsDocShellLoadState. r=kmag
https://hg.mozilla.org/integration/autoland/rev/4f5c28244290
P4: Add an option to set mIsNavigating on the docshell when loading using BrowsingContext. r=kmag
https://hg.mozilla.org/integration/autoland/rev/bb11892e2171
P5: Add DisplayLoadError to BrowsingContext. r=kmag
https://hg.mozilla.org/integration/autoland/rev/180407dc57a8
P6: Add LoadURI to BrowsingContext's webidl. r=kmag
https://hg.mozilla.org/integration/autoland/rev/3b8220a15051
P7: Listen for keyword-uri-fixup events from the parent process in browser.js. r=Gijs
https://hg.mozilla.org/integration/autoland/rev/9b958693a003
P8: Use BrowsingContext::loadURI in RemoteWebNavigation. r=Gijs
https://hg.mozilla.org/integration/autoland/rev/f461f10efa46
P9: Adjust devtools tests to no longer expect a JS stack for parent initiated loads. r=Honza
https://hg.mozilla.org/integration/autoland/rev/ab9c09164df0
P10: Update crash reporter's URL annotation when loading a new URI from the parent. r=kmag
https://hg.mozilla.org/integration/autoland/rev/478897956ee0
P11: Add a flag to ask the parent to not actually load the URI when opening a window, since we'll do it ourselves anyway. r=kmag
Backout by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e6eeb39b298c
Backed out changeset cd0a4cb33b3c for bustages on 2bc84d119d5f . CLOSED TREE
Assignee: nobody → matt.woodrow
Flags: needinfo?(jyavenard)
Pushed by jyavenard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/49065a55694d
P1: Serialize SubstitutingURL fully. r=mayhemer
https://hg.mozilla.org/integration/autoland/rev/43556c937a09
P2: Extend nsDocShellLoadState for the extra options needed to describe front end loads. r=kmag,nika
https://hg.mozilla.org/integration/autoland/rev/ff67cc13cdf3
P3: Move conversion from LoadURIOptions processing into a static constructor for nsDocShellLoadState. r=kmag
https://hg.mozilla.org/integration/autoland/rev/63f5a619b9ef
P4: Add an option to set mIsNavigating on the docshell when loading using BrowsingContext. r=kmag
https://hg.mozilla.org/integration/autoland/rev/591664928bce
P5: Add DisplayLoadError to BrowsingContext. r=kmag
https://hg.mozilla.org/integration/autoland/rev/d8bfec2dc9b6
P6: Add LoadURI to BrowsingContext's webidl. r=kmag
https://hg.mozilla.org/integration/autoland/rev/8ebd563c72a8
P7: Listen for keyword-uri-fixup events from the parent process in browser.js. r=Gijs
https://hg.mozilla.org/integration/autoland/rev/d08a099a22ff
P8: Use BrowsingContext::loadURI in RemoteWebNavigation. r=Gijs
https://hg.mozilla.org/integration/autoland/rev/f1746b2f9dec
P9: Adjust devtools tests to no longer expect a JS stack for parent initiated loads. r=Honza
https://hg.mozilla.org/integration/autoland/rev/cb5e15489635
P10: Update crash reporter's URL annotation when loading a new URI from the parent. r=kmag
https://hg.mozilla.org/integration/autoland/rev/b22733eb880f
P11: Add a flag to ask the parent to not actually load the URI when opening a window, since we'll do it ourselves anyway. r=kmag

This is failing test: https://treeherder.mozilla.org/#/jobs?repo=autoland&group_state=expanded&selectedJob=270422145&resultStatus=testfailed%2Cbusted%2Cexception%2Csuperseded%2Cretry%2Cusercancel&revision=b22733eb880fb4b4c0130c9f7fa90acba5103b03

TEST-UNEXPECTED-FAIL | devtools/client/netmonitor/test/browser_net_websocket_stacks.js | The attached url is correct. - Got http://example.com/browser/devtools/client/netmonitor/test/js_websocket-worker-test.js, expected http://localhost:8080/

1553360Intermittent devtools/client/netmonitor/test/browser_net_websocket_stacks.js | Request #3 has a stacktrace -

TEST-UNEXPECTED-FAIL | devtools/client/netmonitor/test/browser_net_websocket_stacks.js | The tooltip file is correct. - Got http://example.com/browser/devtools/client/netmonitor/test/js_websocket-worker-test.js, expected http://localhost:8080/

1553360Intermittent devtools/client/netmonitor/test/browser_net_websocket_stacks.js | Request #3 has a stacktrace -

TEST-UNEXPECTED-FAIL | devtools/client/netmonitor/test/browser_net_websocket_stacks.js | The displayed domain is correct. - Got example.com, expected localhost:8080

1553360Intermittent devtools/client/netmonitor/test/browser_net_websocket_stacks.js | Request #3 has a stacktrace -

TEST-UNEXPECTED-FAIL | devtools/client/netmonitor/test/browser_net_websocket_stacks.js | The tooltip domain is correct. - Got example.com (127.0.0.1:8888), expected localhost:8080 (127.0.0.1:8888)

1553360Intermittent devtools/client/netmonitor/test/browser_net_websocket_stacks.js | Request #3 has a stacktrace -

TEST-UNEXPECTED-FAIL | devtools/client/netmonitor/test/browser_net_websocket_stacks.js | The displayed cause is correct. - Got script, expected websocket

I'm not familiar with this change and Matt asked me to get this landed while I'm away.

Could you advise on a solution for these errors?

Thank you.

Flags: needinfo?(matt.woodrow) → needinfo?(odvarko)

Oh, I think I know what it is.

This depends on DocumentChannel to be active of course.

Flags: needinfo?(odvarko)
Attachment #9099770 - Attachment is obsolete: true
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cbaad5501956
P1: Serialize SubstitutingURL fully. r=mayhemer
https://hg.mozilla.org/integration/autoland/rev/fe1d075d3ea4
P2: Extend nsDocShellLoadState for the extra options needed to describe front end loads. r=kmag,nika
https://hg.mozilla.org/integration/autoland/rev/b7e483ca9f71
P3: Move conversion from LoadURIOptions processing into a static constructor for nsDocShellLoadState. r=kmag
https://hg.mozilla.org/integration/autoland/rev/a3ba805d6d0c
P4: Add an option to set mIsNavigating on the docshell when loading using BrowsingContext. r=kmag
https://hg.mozilla.org/integration/autoland/rev/6bcb0faec3f2
P5: Add DisplayLoadError to BrowsingContext. r=kmag
https://hg.mozilla.org/integration/autoland/rev/7e9b2f793a7d
P6: Add LoadURI to BrowsingContext's webidl. r=kmag
https://hg.mozilla.org/integration/autoland/rev/07cd37c9540e
P7: Listen for keyword-uri-fixup events from the parent process in browser.js. r=Gijs
https://hg.mozilla.org/integration/autoland/rev/19e6ea5c3649
P8: Use BrowsingContext::loadURI in RemoteWebNavigation. r=Gijs
https://hg.mozilla.org/integration/autoland/rev/8a8fa9937df6
P9: Adjust devtools tests to no longer expect a JS stack for parent initiated loads. r=Honza
https://hg.mozilla.org/integration/autoland/rev/f73ce4525436
P10: Update crash reporter's URL annotation when loading a new URI from the parent. r=kmag
https://hg.mozilla.org/integration/autoland/rev/ba47db006dae
P11: Add a flag to ask the parent to not actually load the URI when opening a window, since we'll do it ourselves anyway. r=kmag
Regressions: 1587373
Regressions: 1588065
Blocks: 1588298

== Change summary for alert #23435 (as of Fri, 11 Oct 2019 14:17:02 GMT) ==

Improvements:

1% Base Content JS windows7-32-shippable opt 3,277,748.00 -> 3,251,150.67
1% Base Content JS windows7-32 opt 3,276,386.67 -> 3,250,468.00
0.41% Base Content JS macosx1014-64-shippable opt 4,134,273.33 -> 4,117,358.67
0.40% Base Content JS linux64 opt 4,128,677.33 -> 4,112,153.33
0.40% Base Content JS linux64-shippable opt 4,128,665.33 -> 4,112,260.00
0.40% Base Content JS linux64-shippable-qr opt 4,128,692.00 -> 4,112,313.33
0.40% Base Content JS windows10-64 opt 4,196,482.67 -> 4,179,510.67
0.40% Base Content JS windows10-64-qr opt 4,196,509.33 -> 4,179,697.33
0.40% Base Content JS windows10-64-shippable opt 4,196,505.33 -> 4,179,564.00
0.40% Base Content JS windows10-64-shippable-qr opt 4,196,532.00 -> 4,179,750.67
0.39% Base Content JS linux64-qr opt 4,128,669.33 -> 4,112,420.00

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=23435

Retroactively moving fixed bugs whose summaries mention "Fission" (or other Fission-related keywords) but are not assigned to a Fission Milestone to an appropriate Fission Milestone.

This will generate a lot of bugmail, so you can filter your bugmail for the following UUID and delete them en masse:

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: --- → M4
You need to log in before you can comment on or make changes to this bug.