Closed Bug 1578736 Opened 1 year ago Closed 8 months ago

Wrong context menu is displayed when right click on the website's link

Categories

(Firefox :: about:logins, defect, P3)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 75
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- disabled
firefox70 --- wontfix
firefox73 --- wontfix
firefox74 --- wontfix
firefox75 --- verified

People

(Reporter: cmuntean, Assigned: mcrawford)

References

Details

Attachments

(3 files)

Attached image context menu.png

[Affected Versions]:

  • Nightly 71.0a1
  • Beta 70.0b3

[Affected Platforms]

  • All Windows
  • All Mac
  • All Linux

[Prerequisites]

  • Have a Firefox profile with multiple logins saved.

[Steps to reproduce]:

  1. Open the Firefox browser with the profile from prerequisites.
  2. Navigate to "about:logins" page.
  3. Select any saved login from the login list.
  4. Right click on the website's link.
  5. Observe the opened context menu.

[Expected results]:

  • The context menu with the "open/copy link" options is displayed.

[Actual results]:

  • The context menu with the "Undo/Cut/Paste/Delete" options is displayed.

[Notes]:

  • Attached a screenshot with the issue.
Priority: -- → P3
Component: Password Manager → about:logins
Product: Toolkit → Firefox

Mass removing [skyline] and [passwords:management] from about:logins bugs which are no longer useful.

Whiteboard: [passwords:management] [skyline]

Hmm, it's an input not a hyperlink.

If I right-click > Select All on the input, then Firefox uses the Link context menu for that text. Would it be useful if a right-click automatically selected the contents before showing a menu?

Assignee: nobody → mcrawford
Status: NEW → ASSIGNED

I think we can display a real <a href=""> here to get the proper context menu. We now do something similar for the password field where we have an input for editing and another for display in non-editing modes, aligning with that would be good.

Hopefully this can fix bug 1567500 too or at least help it.

Blocks: 1567500

(In reply to Matthew N. [:MattN] (PM me if request are blocking you) from comment #4)

Hopefully this can fix bug 1567500 too or at least help it.

Confirmed. This fixes the issue described in Bug 1567500

Pushed by aiakab@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1ccf1ec84fea
Wrong context menu is displayed when right click on the website's link r=jaws
https://hg.mozilla.org/integration/autoland/rev/675a2bd332a6
Revised updatePasswordRevelState to use replaceWith method r=jaws
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 75

Thanks for fixing this Maxx!

Flags: qe-verify+

I have verified this issue and is no longer reproducible with the link displayed in the Login item. Tested on the latest Nightly 75.0a1 build (Build ID: 20200226092757) on Windows 10 x64, Mac 10.14 and Arch Linux.

  • The correct context menu is displayed when clicking on the website's link displayed in the Login item.
  • The options from the context menu work as expected.
  • The link is no longer opened if clicking on the empty area beside the website on Login item.

However, it seems that the fix doesn't apply in "Edit" mode. In "Edit" mode the wrong context menu is still displayed when right click on the website's link. Also, it seems that the website has a different format in "Edit" mode.
I have logged a separate issue for this in bug 1618268.

Since the "status-firefox74" is "fix-optional", I'll leave the "qe-verify+" flag set until a decision is made for Firefox 74.

See Also: → 1618268
Duplicate of this bug: 1618239
Duplicate of this bug: 1601552
Duplicate of this bug: 1589748
Depends on: 1618268
See Also: 1618268
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Regressions: 1619736
You need to log in before you can comment on or make changes to this bug.