DNS: Takes long time to resolve hostnames

VERIFIED DUPLICATE of bug 135724

Status

()

defect
VERIFIED DUPLICATE of bug 135724
17 years ago
17 years ago

People

(Reporter: eirikn, Unassigned)

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

17 years ago
When I try to resolv a hostname 50% of the tries or more uses along time to
resolv the domain, if I try to ping the same domain while mozilla resolvs it, I
get the ip with ping at once, but mozilla still uses forever.

I am useing the newset mozilla from the FreeBSD port tree(Mozilla 1.0)
Reporter: could you give us a specific test case, and steps to reproduce this ?

It's difficult to investigate when you just say 'sometimes it doesn't work'. So
if you can reproduce it, that'll help alot.
Summary: Takes long time to resolv hostnames → Takes long time to resolve hostnames
Reporter

Comment 2

17 years ago
I am haveing problem reproduceing it myself, it justs happens in about 50% of
the tries.

Comment 3

17 years ago
Please provide exact steps. There are two possible causes:

1- Our DNS lookups are somewhat inefficient.

2- BSD has IPv6+DNS related issues.
Reporter

Comment 4

17 years ago
I have changed the nameserver I have been useing and it works alot better now,
still don't understand why the lookup to alot longer time from mozilla then ping
but it works anyway. 

The steps I took were entering an adresse and push enter.
Reporter

Comment 5

17 years ago
The long time wait seemse to come when I try to enter two or more web pages at
the same time.

Updated

17 years ago
Summary: Takes long time to resolve hostnames → DNS: Takes long time to resolve hostnames

Comment 6

17 years ago
I'v seen similiar behavior using Mozilla 1.1 and Mozill 1.0 on linux. I can't
provide steps to reproduce but mozilla will periodically get in a state where it
will take a very long time to load a page, the whole time the status bar will
say "resolving xxxxx". It takes long enough that while waiting I often start
netscape 4.7, go to the page I'm trying to get to and use that until mozilla
gets unstuck.

It does seem to enter this state when I'm trying to load things in multiple tabs
at the same time, but that could just be because I'm almost always loading
things in multiple tabs at the same time. 

If I wait long enough. Eventually, all the tabs that are trying to load pages
will  load their respective pages and things will be fine for a while.
Eventually it will happen again.

If I don't wait and I close mozilla and then restart it I can usually load the
page I was trying to load without a problem.

I also use mozilla on a windows box and haven't experienced this behavior on there.

Comment 7

17 years ago
Marking duplicate of bug 135724.

*** This bug has been marked as a duplicate of 135724 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 8

17 years ago
V/dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.