When saved as xxx.eml, file fails to display some formatting in journal articles forwarded by e-mail

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
17 years ago
10 years ago

People

(Reporter: michael.graubart7, Assigned: mscott)

Tracking

({qawanted})

Trunk
PowerPC
Mac System 9.x
qawanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.1a+) Gecko/20020715
BuildID:    2002071503

I received an article from an online journal forwarded to me by e-mail. It
contains a headline in large, bold type and also a large, red drop-capital at
the start of the body of the text. Mozilla displayed this correctly, but when it
was saved to disk as xxx.eml, this file showed the bold headline, but the large
red drop-capital had become a small black inline capital.

When this was repeated in Netscape 4.79, the saved file contained all the
formatting, including the drop-capital.

If the acknowledgement of this bug report includes an e-mail address, I shall
forward the article in question for the recipient to experiment with.

Reproducible: Didn't try
Steps to Reproduce:
1.When I have forwarded the article, open it and note its appearance (esp. the
large red drop-capital).
2.Save it to disk as xxx.eml.
3.Open this file.

Actual Results:  The bold headline is correctly displayed, but the large red
drop-capital has become a small black inline capital.

Expected Results:  All the formatting, including the large red drop-capital,
should be shown when the saved file is opened.

Mac G3 (old beige).  OS 9.2.2.  Classic theme.

Comment 1

17 years ago
*** Bug 157884 has been marked as a duplicate of this bug. ***

Updated

17 years ago
QA Contact: gayatri → gchan
(Reporter)

Comment 2

17 years ago
Created attachment 91835 [details]
Two screenshots combined into one Word 2001 document

This Word document shows, first, the newswpaper article as it appears in my
mail window, and, second, what it looks like when saved as xxx.eml and opened. 
Note the red drop-capital at the start of the text in the first, which has been
replaced by an ordinary black inline capital in the second.  But the headline
formatting (size, bold) is retained.

Comment 3

17 years ago
can you attach original mesg to this bug?
(Reporter)

Comment 4

17 years ago
This bug is still apparent in Build No. 2002071808.

Comment 5

16 years ago
Adding qawanted. We need the .eml message attached to this bug per comment 3, Michael.
Keywords: qawanted
(Reporter)

Comment 6

16 years ago
Created attachment 94002 [details]
Saved (.eml) e-mail message with some missing formatting.
(Reporter)

Comment 7

16 years ago
Created attachment 94014 [details]
E-mail message (article from periodical) saved as .eml, with missing formatting.

Comment 8

16 years ago
In the first example, the red M is, in fact, an image.

<img alt="M" src="cid:part1.03040100.06010606@btinternet.com" align="left" border="0"
 _base_href="http://www.nytimes.com/2002/07/15/books/15MAME.html?pagewanted=print&
amp;position=top">

I guess that's a URN there in the SRC attribute. What that's supposed to indicate, I don't know. 
mscott@netscape.com, any thoughts?

Comment 9

15 years ago
Bugs are targeted at mac classic, which is dead. Marking WONTFIX. Please reopen,
if you can reproduce the bug on Mac OS X with 1.5beta or later.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.