Closed Bug 1579030 Opened Last month Closed 29 days ago

TB 68: Invite Attendee dialog is partly broken and scroller is very laggy

Categories

(Calendar :: Dialogs, defect)

Lightning 7.0
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: d.spitznagel, Assigned: darktrojan)

References

Details

Attachments

(5 files, 1 obsolete file)

Attached image invite.jpg

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0

Steps to reproduce:

  1. Opened calendar and doubleclicked into it to open "New Event" dialog.
  2. Pressed "Invite Attendees".
  3. Dialog pops up and shows successfully freebusy information.
  4. Started entering a valid email address present in my addressbooks.

Actual results:

  1. The desired address was not resolved.
    Digging deeper into this problem I found out, that only addresses from "Collected Addresses" are being resolved.
    In TB 60.8.0 matches from "all" addressbooks where shown.
  2. After adding the correct address by hand the freebusy information was read from the caldav server sucessfully but the timebar from that attendee looked displaced.
  3. The scrollbar in the timeview is missing right scroll button.
  4. Using the scrollbar with pressed left mouse button and move it left or right is laggy and does not really scroll - it jumps!

Expected results:

  1. All matching email addresses from all address books should work, not only from Collected Addresses".
  2. Timebar from attendees should look like the one from organizer.
  3. Scrollbar should habe left and right button and scroll correctly.
Flags: needinfo?(geoff)
Version: Lightning 70 → Lightning 7.0

Hmm, yes, the right scroll button is missing and it doesn't seem to scroll very well. I don't have CalDAV, so I can't speak to the attendee timebar being displaced.

Address entry works however, I've just added tree attendees from my Personal Address Book. Address auto-complete uses the same underlying function everywhere in TB, so I'd be surprised if this one here were special. Does address entry work correctly on the Write window and when adding addresses to a mailing list?

In "write" window ALL address books are being used (also cardDAV). Mailing lists are also being shown but do not expand, but this is intended I think?
We use "Provider for CalDAV & CardDAV from John Bieling/Jobisoft" for it.

I did some more tests today and you seem right. Attendee Invite dialog uses only "local" addresses, "local" mailing lists (which get expanded) from "local" addressbooks.
Sorry for the confusion.
Only cardDAV addresses are NOT working but they work in the "write" dialog and everywhere in TB 60.8.0.

The timebar is also displaced for me when I use an address from local addressbook.
The bars look like a "wall" instead of a "grid" (see screenshot).

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(geoff)

This brings the end of the scrollbar back into view and lines up the grid again.

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Attachment #9091367 - Flags: review?(paul)
Attachment #9091367 - Flags: approval-calendar-esr?(paul)
Attachment #9091367 - Flags: approval-calendar-beta?(paul)
Comment on attachment 9091367 [details] [diff] [review]
1579030-attendees-again-1.diff

Review of attachment 9091367 [details] [diff] [review]:
-----------------------------------------------------------------

Code changes look fine.  When I tried it the scroll bar was working as expected again (thank goodness!) (with no left/right buttons, which seems fine and good to me), and the grid looked correct when adding attendees besides the organizer.  The part about address book auto-filling would make sense to tackle in a separate bug.
Attachment #9091367 - Flags: review?(paul)
Attachment #9091367 - Flags: review+
Attachment #9091367 - Flags: approval-calendar-esr?(paul)
Attachment #9091367 - Flags: approval-calendar-esr+
Attachment #9091367 - Flags: approval-calendar-beta?(paul)
Attachment #9091367 - Flags: approval-calendar-beta+
Keywords: checkin-needed

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/cca546ac6667
Fix several layout issues in attendees dialog. r=pmorris

Status: ASSIGNED → RESOLVED
Closed: Last month
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 71

TB 68.1 ESR / Cal 7.0:
https://hg.mozilla.org/releases/comm--esr68/rev/9317dad8cb7fd80a47cb3b40253c73127f776535

Hello Mr. Spitznagel, I'll provide you with a download link for the 68.1 pre-release later.

Target Milestone: 70 → 7.0

Hi, the invitee dialogue looks OK in this build:
https://queue.taskcluster.net/v1/task/PlRnlipYSb-zOdZJQzh_rg/runs/0/artifacts/public/build/install/sea/target.installer.exe

However, if you run it on an existing profile, it's very hard to convince the Lightning add-on to refresh. I can give you more instructions, but it would be easiest to try it on a new profile.

Flags: needinfo?(d.spitznagel)

@Jork K
You are right, it did not work with my existing TB 68.1 profile - nothing changed.
What can I do to force Lightning to refresh? Removing the profile is not a real solution.

Flags: needinfo?(d.spitznagel)

It's a long process:

  1. Remove the Lightning Extension in the Add-ons Manager
  2. Reset pref extensions.installedDistroAddon.{e2fda1a4-762b-4020-b5ad-a41df1933103}
  3. Restart TB with command line -purgecaches

That should bring back TB with a new version of LN. Let's see whether that works for you.

I was able to refresh Lightning following your advice.
The timeline looks now correct when adding attendee > It shows a grid instead of a wall.

The right scroll button is also visible now but both (left and right scroll button) are doing nothing but moving the scroll bar from left to right.
They don't change (move) the timeline window above!!!!

The scroll bar is also not working correctly when holding left mouse button and move right into future.
For example...
The invitation starts on 13. September.... I move the scrollbar to the right... it shows 14. September... I move the scrollbar further right... it shows AGAIN 14. September... I move the scrollbar further right... it shows AGAIN and AGAIN 14. September (multiple times) until I reach the end of the scroll bar.

Yes, seems totally broken still. On Daily I see new dates when scrolling, but on 68 ESR I don't. On both, the arrows only move the bar, not the dates above :-( - Sigh. Sadly we're relatively late in the TB 68.1 ESR release process, so this won't be fixed before we ship. I noticed that "Next Slot" moves the dates forward.

Flags: needinfo?(paul)
Flags: needinfo?(geoff)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

I'm aware there are bigger issues. I only fixed what I said I fixed. My objective was to get it somewhere approaching usable, but the thing needs a complete overhaul.

As far as the scrollbar is concerned, in my experience it does work if you drag it.

Flags: needinfo?(geoff)

As far as the scrollbar is concerned, in my experience it does work if you drag it.

Sadly that's not the case in TB 68. For example, if you set it to 25%, the same days keep scrolling past you as you drag from left to right. I feel like looking in a surreal Escher picture. Please take another look. It works OK on trunk.

Flags: needinfo?(geoff)

I don't know what's causing scrolling problems that I don't see, but throwing the whole thing out and doing it in a different way should work, right? ;-)

Flags: needinfo?(geoff)
Attachment #9091981 - Flags: review?(paul)
Attachment #9091981 - Flags: approval-calendar-esr?(paul)
Attachment #9091981 - Flags: approval-calendar-beta?(paul)
Attached patch esr68.patch (obsolete) — Splinter Review

Rebased to ESR 68 with its 4-spaces indents. Note: I did it the "smart" way using patch -l, but still three hunks had to be done manually. Let's see whether it works:
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=e44d40877e1455d3546be5e15f4244c9edfa69a2
Build for Windows and Linux with all tests.

Oh, I saw that most of the hunks got applied with two spaces, that will give linting errors:
https://hg.mozilla.org/try-comm-central/graph/e44d40877e1455d3546be5e15f4244c9edfa69a2
https://hg.mozilla.org/try-comm-central/rev/8c544474920ddeeb2903a4ca860a0e56a1ec524a

Flags: needinfo?(paul)
Attachment #9092028 - Flags: approval-calendar-esr?(paul)
Attached patch esr68.patchSplinter Review
Attachment #9092028 - Attachment is obsolete: true
Attachment #9092028 - Flags: approval-calendar-esr?(paul)
Attachment #9092029 - Flags: approval-calendar-esr?(paul)
Comment on attachment 9091981 [details] [diff] [review]
1579030-attendees-again-again-1.diff

Review of attachment 9091981 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.  Scrolling still works fine here, and yay for simpler code.
Attachment #9091981 - Flags: review?(paul)
Attachment #9091981 - Flags: review+
Attachment #9091981 - Flags: approval-calendar-esr?(paul)
Attachment #9091981 - Flags: approval-calendar-esr+
Attachment #9091981 - Flags: approval-calendar-beta?(paul)
Attachment #9091981 - Flags: approval-calendar-beta+
Comment on attachment 9092029 [details] [diff] [review]
esr68.patch

Review of attachment 9092029 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #9092029 - Flags: approval-calendar-esr?(paul) → approval-calendar-esr+

Sorry, but that doesn't work in TB 68. There is no grid, the scrollbar is as wide as the area above, you can't scroll, neither with the arrows, nor with the scrollbar which occupies the entire space.

Paul, have you tried my try build?
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=24727634131facf68c7a40b024466a1f07391786

Since TB 70 and TB 71 are working, what's the point of the patch apart from the "yay for simpler code"?

Flags: needinfo?(paul)
Flags: needinfo?(geoff)

Scrolls OK in the trunk version. But if the scroll arrows are dysfunctional, why not remove them? That goes for 68, too.

Hm... Jorg, I just tried it on 68.1.0 (thanks for the tip on how to find the build) and it works fine here on Linux. The grid and scrollbar look fine, and scrolling works as expected. There are no scrollbar buttons, but that is the default for this platform, AFAICT. (I noticed that the blue column that indicates when the event is does not exactly line up with the grid, it's a little too far to the right, but that's unrelated to Geoff's patch.) I assume you tested it on Windows? Maybe it's a platform thing?

Flags: needinfo?(paul)
Attached image invitees.png

Sorry, but on Windows in a new profile this is totally borked. Not even the invitee entry works, enter opens a new entry below, but the cursor doesn't move there.

And this comes out on the error console:
TypeError: templateNode is undefined
calendar-event-dialog-attendees-custom-elements.js:2819:23
TypeError: freebusy is null
calendar-event-dialog-attendees-custom-elements.js:2872:13
TypeError: roleStatusIcon is null
calendar-event-dialog-attendees-custom-elements.js:722:13
TypeError: freebusy is null
calendar-event-dialog-attendees-custom-elements.js:2872:13
TypeError: roleStatusIcon is null
calendar-event-dialog-attendees-custom-elements.js:722:13
TypeError: freebusy is null
15 calendar-event-dialog-attendees-custom-elements.js:2872:13
TypeError: freebusy is null
119 calendar-event-dialog-attendees-custom-elements.js:2872:13

Note the 119 occurrences and I didn't even past all the errors. Maybe that's due to an empty profile with no identities defined. I'll try on another profile.

Certainly not ready for prime time.

Yes, seems OK on an existing profile with identities and such. Paul, can you try a new profile, please.

EDIT: I was going to say: We missed TB 68.1 ESR, so this can be tweaked to work when Geoff returns. For now, I won't land it.

Flags: needinfo?(paul)

Yes, trunk totally misbehaves on an empty profile. So that should be easy to fix then.

Comment on attachment 9091981 [details] [diff] [review]
1579030-attendees-again-again-1.diff

Messing up badly on new profile, but otherwise OK on trunk and 68.
Attachment #9091981 - Flags: feedback-

Well, the current version of 68.1 without the follow-up patch can also not handle an empty profile. TB 60 works OK on an empty profile.

(In reply to Jorg K (GMT+2) from comment #25)

Yes, seems OK on an existing profile with identities and such. Paul, can you try a new profile, please.

I tried it with a new profile on trunk and can confirm it's badly broken. After I added an email account things worked again. Then I tried removing the account and things still worked. The email address for the removed account was already there on the top line upon opening the dialog.

Edit: after restarting TB with the account removed things were broken again.

Flags: needinfo?(paul)
Duplicate of this bug: 1577732
Flags: needinfo?(geoff)

OK, Geoff filed bug 1581486 for the "no mail account" issue. So let's land the patch here.

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/08374e5b0ac0
Change how horizontal scrolling works in attendees dialog. r=pmorris DONTBUILD

Status: REOPENED → RESOLVED
Closed: Last month29 days ago
Resolution: --- → FIXED

Paul, should I land the patch for TB 68 or you want to do the prettifying first? Then we can used the trunk patch.

I'd say let's hold off and land this on 68 after 68 is auto-formatted with Prettier.

TB 68.1.1 or TB 68.2 / Cal 7.0.1.1 or 7.0.2:
https://hg.mozilla.org/releases/comm-esr68/rev/091af0b65a5946134a041b53f1e7b3ce5e8cc4c5

I landed the rebased ESR 68 patch since I had to do a new 68 build for other reasons and I wanted to try it for real. Whether it got landed before or after prettify didn't really matter. Silly to ask when I ignored the reply, but other things came up.

Hello Mr. Spitznagel, try this one if you can manage to get Lightning updated:
https://queue.taskcluster.net/v1/task/FtpXvN-jR8y_zBd4MRv4_g/runs/0/artifacts/public/build/install/sea/target.installer.exe

This is another 68.1.0 which will come out as 68.1.1 later.

Hello Jork K,
I've installed the 32bit one from Comment 38 > no Lightning update issues.
What I have tested...

  1. Scroller works as expected when dragging > timeline above moves too as expected.
  2. Left and right scroller buttons move the scrollbar very very very slow and do not change timeline above.
  3. Freebusy Info is looking correkt > grid style.
  4. Adding attendee from CardDAV addressbook does NOT autocomplete but SHOWS freebusy info when entered in FULL (complete).

result:
1 + 3 > fixed
2 + 4 > partly broken

Thanks for testing. Can you please file two new bugs for items 2 and 4 and CC me and :darktrojan. This bug has become too confusing now.

You need to log in before you can comment on or make changes to this bug.