Closed Bug 1579108 Opened 2 years ago Closed 5 months ago

[Linux] The "Copy" buttons of the username and password fields are not aligned

Categories

(Firefox :: about:logins, defect, P3)

Desktop
Linux
defect

Tracking

()

VERIFIED FIXED
86 Branch
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox-esr78 --- wontfix
firefox69 --- disabled
firefox70 --- wontfix
firefox71 --- wontfix
firefox84 --- wontfix
firefox85 --- wontfix
firefox86 --- verified

People

(Reporter: cmuntean, Assigned: kenrick95)

References

Details

(Keywords: regression)

Attachments

(2 files)

[Notes]:

  • The issue is not reproducible on Windows and Mac OS.

[Affected Platforms]

  • Ubuntu 18.04
  • Ubuntu 16.04

[Steps to reproduce]:

  1. Open the latest Nightly browser and navigate to "about:logins" page.
  2. Click the "Create New Login" button.
  3. Enter a valid Website Address.
  4. Enter a short username and password and click the "Save" button.
  5. Observe the "Copy" buttons of the username and password fields.

[Expected results]:

  • The buttons are aligned.

[Actual results]:

  • The buttons are not aligned.

[Additional Notes]:

  • Attached a screenshot with the issue.

This wasn't reproducible on Fedora, so this could be Ubuntu specific.

I'm guessing the widget code on Ubuntu is giving a larger default width for inputs on Ubuntu which could be causing this.

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Version: Trunk → unspecified

Mass removing [skyline] and [passwords:management] from about:logins bugs which are no longer useful.

Whiteboard: [passwords:management] [skyline]

This issue is from using the font called "Ubuntu" (it is the default font in Ubuntu OS). I can reproduce it on Windows too if I set the page's default font-family using "Ubuntu" font

Implementing grid layout using flex may sometimes triggers edge cases where some columns go out of alignment. In this bug, the misalignment is due to the different length value given by -moz-available when Ubuntu font is used on the page.

Assignee: nobody → kenrick95
Status: NEW → ASSIGNED
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/8e5172537013
Change the form in login-item to grid so that the copy buttons can reliably align r=sfoster,ntim
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 86 Branch

I have verified this issue on the latest Nightly 86.0a1 (Build ID: 20210111215143) on Ubuntu 20.04 x64 and Linux Mint 20.

  • The "Copy" buttons are correctly aligned. I have also verified if both "Copy" buttons are correctly aligned if the username or password has a very long string.

I have also verified these changes on Windows 10 x64 and macOS 10.15.6 and now the "Copy" buttons are correctly aligned if the password is longer than the username.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.