Closed Bug 1579149 Opened 2 years ago Closed 2 years ago

Allow clustering passwords for single sign-on

Categories

(Toolkit :: Password Manager, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1120684
Tracking Status
firefox71 --- affected

People

(Reporter: bugzilla.mozilla.org, Unassigned)

Details

I have a few dozen sites that all use the same underlying single sign-on system but they do not provide enough information to the web browser to properly abstract into a single entry in the password manager.

I'd like to fix that.

I propose a new Cluster button in the Saved Logins view, located near the Remove and Remove All buttons. If zero or one rows are selected, it will be grayed out (like Remove when zero rows are selected).

When this button is pressed:

  • If all selected sites/clusters have the same username and password: cluster (see below)
  • Otherwise, prompt the user for:
    • Cluster name (free-form text string, okay to look like a URI)
      • default to longest common string between site names, replacing the scheme with "cluster: "
    • Select one of the rows (default: the most recently changed) or enter manually
      • If entering manually, Username and Password
    • Cancel/OK

Clusters in the display are nested and collapsed by default, showing the collapse/expand button and cluster name instead of the site. Expand the cluster and you'll see all of the sites contained within. Right-click on a site in a cluster and there will be a Remove from cluster option. The cluster is sorted as if it were a site. Sites within the cluster are sorted among themselves the same way the top-level sorting is.

Right-click on the cluster itself and the options will be:

  • Edit Cluster Name
  • Separate Cluster
  • Expand/Collapse (whichever is valid)

  • Copy Cluster Username
  • Edit Cluster Username

  • Copy Cluster Password
  • Edit Cluster Password

When changing a clustered site's password, the options should be:

  • Would you like to update this login?
    It is currently in password cluster "cluster name"
  • [username]
  • [masked password]
  • Don't Update
  • Un-cluster & Update
  • Update Cluster (default, colored as such)

(Un-cluster? De-cluster? Break? Split? Coming up with concise and self-explanatory phrasing for that button is hard, and there's a lot of translations to consider too.)

Subdomain support in Fx71 should help where the top-level domain is the same, otherwise bug 1120684 is the first step to sharing logins across different domains so duping to there for now.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1120684
You need to log in before you can comment on or make changes to this bug.