Closed Bug 1579411 Opened 5 months ago Closed 4 months ago

dark theme support

Categories

(Calendar :: Calendar Views, enhancement)

Lightning 68
enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: frederic.parrenin, Assigned: Paenglab)

References

Details

Attachments

(4 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

I have a debian 10 machine with the latest TB 68.
I switched to a dark theme in firefox/thunderbird.
I went to the calendar.

Actual results:

The calendar still has a white theme (see attached).

Expected results:

The calendar should have a dark theme as well.

Type: defect → enhancement
Component: General → Calendar Views
Version: unspecified → Lightning 7.0

Alessandro, what do you think about this colours? With light WE-themes I'm using the default colours for the weekend and the selected day, so this should be okay. For the dark themes I'm using dark versions of the default colours. Or do you propose different colours?

Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9092917 - Flags: ui-review?(alessandro)
Comment on attachment 9092917 [details] [diff] [review]
1579411-themeable-minimonth-calendarviews.patch

Review of attachment 9092917 [details] [diff] [review]:
-----------------------------------------------------------------

It looks pretty good, great work.
I think I'll need to sit on these colours for a while and tweak them a bit, but for now this is perfect and good to land.
Attachment #9092917 - Flags: ui-review?(alessandro) → ui-review+
Comment on attachment 9092917 [details] [diff] [review]
1579411-themeable-minimonth-calendarviews.patch

Thank you Alessandro. Now the code review.
Attachment #9092917 - Flags: review?(geoff)
Comment on attachment 9092917 [details] [diff] [review]
1579411-themeable-minimonth-calendarviews.patch

Nice.
Attachment #9092917 - Flags: review?(geoff) → review+

Thanks.

Keywords: checkin-needed
Comment on attachment 9092917 [details] [diff] [review]
1579411-themeable-minimonth-calendarviews.patch

This patch applies to beta too. For ESR I'll attach a rebased patch when I'm home.
Attachment #9092917 - Flags: approval-calendar-beta?(philipp)
Comment on attachment 9092917 [details] [diff] [review]
1579411-themeable-minimonth-calendarviews.patch

Can someone approve this.
Flags: needinfo?(geoff)
Attachment #9092917 - Flags: approval-calendar-beta?(philipp) → approval-calendar-beta?(paul)

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/3fd730919801
Make the MiniMonth and the calendar view themeable. r=darktrojan ui-r=aleca

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 71
Comment on attachment 9092917 [details] [diff] [review]
1579411-themeable-minimonth-calendarviews.patch

I don't see the rush but go ahead.
Flags: needinfo?(geoff)
Attachment #9092917 - Flags: approval-calendar-beta?(paul) → approval-calendar-beta+
Attached image Default-Theme.png

Is this how it is supposed to look like on Windows 10?

When using Thunderbird default theme I get light or dark colors based on Windows 10 Settings > Personalization > Colors > Default App Mode: Light or Dark.

With dark mode

  • The labels for the time row in the calendar view are hard to read. Maybe make them brighter like the column labels?
  • The days in mini-month have border around them. I do not like that. Maybe make them border-less like in Light mode?
  • The week number in mini-month looks same as day label. Maybe make them more distinguishable from each other, like in Light mode?
  • The purble-ish and green-ish color looks odd to me. Maybe we can use color from Thunderbird like the Blue that marks selected tab to mark selected day?

When "Optimize colors for accessibility" is enabled in Thunderbird preferences, the mini-month and calendar view switch back to white. Is that expected?

And if the colors for default theme are mostly derived from operating system, maybe we don't need the "Optimize colors for accessibility" preference anymore but make it default?

Flags: needinfo?(richard.marti)

Well, the background is dark, that's the main point. I'll land it on beta now, we can always adjust it later.

ESR version.

Flags: needinfo?(richard.marti)
Attachment #9093937 - Flags: approval-calendar-esr?(paul)

(In reply to Stefan Sitter [:ssitter] from comment #10)

Created attachment 9093893 [details]
Default-Theme.png

Is this how it is supposed to look like on Windows 10?
Yes
When using Thunderbird default theme I get light or dark colors based on Windows 10 Settings > Personalization > Colors > Default App Mode: Light or Dark.

With dark mode

  • The labels for the time row in the calendar view are hard to read. Maybe make them brighter like the column labels?
    I'll look to make them brighter.
  • The days in mini-month have border around them. I do not like that. Maybe make them border-less like in Light mode?
    Good catch.
  • The week number in mini-month looks same as day label. Maybe make them more distinguishable from each other, like in Light mode?
    I try to make them a bit less bright.
  • The purble-ish and green-ish color looks odd to me. Maybe we can use color from Thunderbird like the Blue that marks selected tab to mark selected day?
    See comment 2. It's a starting point and needs some improvement. The blue highlight colour is different on the platforms and we need a common color...and not only one, at least three of them for "today", "selected" and "weekend".
    When "Optimize colors for accessibility" is enabled in Thunderbird preferences, the mini-month and calendar view switch back to white. Is that expected?
    Yes, this is by design to make the systemcolors have priority.
    And if the colors for default theme are mostly derived from operating system, maybe we don't need the "Optimize colors for accessibility" preference anymore but make it default?
    The colours aren't derived from OS but hardcoded in the themes. "Optimize colors for accessibility" is mostly for the High contrast themes to use the system colours to not use the default Lightning colours for good sighted people.

I'll address the issues above in a new bug.

Depends on: 1582564
Attachment #9093937 - Flags: approval-calendar-esr?(paul) → approval-calendar-esr+
Depends on: 1582830
You need to log in before you can comment on or make changes to this bug.