Closed Bug 1579418 Opened 3 months ago Closed 3 months ago

Sometimes the “Custom URLs..” option from the “Homepage and new windows” dropdown menu is inaccessible via keyboard navigation

Categories

(Firefox :: Preferences, defect, P1)

All
Windows
defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- verified
firefox69 --- wontfix
firefox70 --- verified
firefox71 --- verified

People

(Reporter: emilghitta, Assigned: mkaply)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image homepage.gif

Affected versions

  • 71.0a1 (BuildId:20190905215710)
  • 70.0b3 (BuildId:20190902191027)
  • 69.0 (BuildId:20190827005903)
  • 68.1.0esr (BuildId:20190826132627)

Unaffected versions

  • 60.9.0esr (BuildId:20190901094603)

Affected platforms

  • Windows 10 64bit
  • Windows 7 64bit

Unaffected platforms

  • Ubuntu 18.04 64bit
  • macOS 10.13.6

Steps to reproduce

  1. Launch Firefox.
  2. Access the about:preferences#home page.
  3. Click on the “Homepage and new windows” dropdown menu
  4. Navigate through the available options via up and down arrow keys several times.

Expected result
All available options are accessible via keyboard navigation.

Actual result
Sometimes, the “Custom URLs…” option is skipped and inaccessible.

Regression Range

Notes
For further information regarding this issue please observe the attached screencast

Summary: Sometimes the “Custom URLs..” option from the “Homepage and new windows” is inaccessible via keyboard navigation → Sometimes the “Custom URLs..” option from the “Homepage and new windows” dropdown menu is inaccessible via keyboard navigation

Hi Mike!

It seems that mozregression pointed out Bug 1568855 for causing this regression.

Can you please have a look ?

Thanks!

Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(mozilla)

What's happening here is that the act of clearing the pref is causing syncFromHomePref to be invoked and because there is no value (about:blank), it thinks we're rending a regular Firefox homepage.

Because our homepage prefs depend on the value of browser.startup.homepage and browser.startup.page, it makes this difficult to fix. Still working on it.

Flags: needinfo?(mozilla)
Assignee: nobody → mozilla
Status: NEW → ASSIGNED
Priority: -- → P1
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/8b600119cc12
Don't reset homepage unless we need to. r=jaws
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Comment on attachment 9091157 [details]
Bug 1579418 - Don't reset homepage unless we need to.

Beta/Release Uplift Approval Request

  • User impact if declined: Can't select custom homepage with keyboard (regression)
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: In bug (originally found by test)
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Has testcase, easily verifiable.
  • String changes made/needed:

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Regression
  • User impact if declined: Can't select custom homepage with keyboard (regression that went on ESR)
  • Fix Landed on Version: 71
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Has testcase, easily verifiable.
  • String or UUID changes made by this patch:
Attachment #9091157 - Flags: approval-mozilla-esr68?
Attachment #9091157 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

This issue is verified fixed using Firefox 71.0a1 (BuildId:20191002214349) on Windows 10 64bit.

Pending beta and esr uplift.

Flags: needinfo?(emil.ghitta)

Comment on attachment 9091157 [details]
Bug 1579418 - Don't reset homepage unless we need to.

Followup from a regression from 1568855 which we took in 70 and corresponding esr.
OK for uplift for beta 13 and esr.

Attachment #9091157 - Flags: approval-mozilla-esr68?
Attachment #9091157 - Flags: approval-mozilla-esr68+
Attachment #9091157 - Flags: approval-mozilla-beta?
Attachment #9091157 - Flags: approval-mozilla-beta+

This issue is verified fixed using Firefox 70.0b13 (2091007220302) and Firefox 68.2.0esr (2019004193514) on Windows 10 64bit.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(emil.ghitta)
You need to log in before you can comment on or make changes to this bug.