Closed Bug 1579654 Opened 2 years ago Closed 2 years ago

Can no longer set breakpoints for Tree Style Tab

Categories

(DevTools :: Debugger, defect, P2)

defect

Tracking

(firefox-esr60 unaffected, firefox-esr68 unaffected, firefox69 unaffected, firefox70 verified, firefox71 verified)

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified
firefox71 --- verified

People

(Reporter: Kwan, Assigned: bhackett1024)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [debugger-mvp])

Attachments

(1 file)

What were you doing?

  1. Install Tree Style Tab
  2. Open about:debugging
  3. Inspect Tree Style Tab
  4. Open Debugger
  5. Try and set a breakpoint anywhere

What happened?

All line numbers in the debugger de-emphasised to indicate no breakpoints available & can't set one anywhere.

What should have happened?

Some line numbers highlighted, able to create breakpoints.

Anything else we should know?

This was reported by a user in #firefox

$ mozregression --good 69 -e ~/Downloads/Software/tree_style_tab-3.1.7-fx.xpi -a "about:debugging"
[...]
16:24.21 INFO: Last good revision: 8637163553058a09e835ee6d8e53a09735b1b1ec
16:24.21 INFO: First bad revision: efe4a620841ca7032485544176fb051a642c01bc
16:24.21 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=8637163553058a09e835ee6d8e53a09735b1b1ec&tochange=efe4a620841ca7032485544176fb051a642c01bc

Flags: needinfo?(bhackett1024)
Keywords: regression
Priority: -- → P2

Sorry for the delay here. With the changes in bug 1572280, when we detect that some scripts in a file have been GC'ed, we try to reparse the file to find the full set of breakpoint positions. In this case that reparse fails due to a syntax error, and we end up discarding all the breakpoint positions from the scripts that haven't been GC'ed. This change fixes this so that we don't discard the positions we know about if reparsing fails, though it would also be good to look into why the reparse is failing (probably different compilation options between the initial parse and reparse).

Flags: needinfo?(bhackett1024)
Pushed by bhackett@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/baf21161ae8e
Use old set of scripts if reparsing for breakpoint positions fails, r=jlast.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Assignee: nobody → bhackett1024
Blocks: dbg-71
Whiteboard: [debugger-mvp]

Is this something we should consider uplifting to Beta?

Flags: needinfo?(bhackett1024)

I think so.

Comment on attachment 9092940 [details]
Bug 1579654 - Use old set of scripts if reparsing for breakpoint positions fails, r=jlast.

Beta/Release Uplift Approval Request

  • User impact if declined: Can't set breakpoints in certain scripts
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Simple fix for a regression from bug 1572280, restoring the previous behavior if reparsing a script fails.
  • String changes made/needed:
Flags: needinfo?(bhackett1024)
Attachment #9092940 - Flags: approval-mozilla-beta?

Comment on attachment 9092940 [details]
Bug 1579654 - Use old set of scripts if reparsing for breakpoint positions fails, r=jlast.

Fix for recent regression, let's uplift for beta 9.

Attachment #9092940 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

I've reproduced this issue with Fx 71.0a1 (2019-09-07) on Windows 10 x64.
The issue is verified fixed with Fx 71.0a1 (2019-09-24) and Fx 70.0b9 on Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.