Closed Bug 1579713 Opened 2 years ago Closed 2 years ago

Intermittent devtools/client/webreplay/mochitest/browser_dbg_rr_breakpoints-06.js | Test timed out | A promise chain failed to handle a rejection: 'getEnvironment' active request packet to 'server0.conn5.child1/frame152' can't be sent as the connection ju

Categories

(Core Graveyard :: Web Replay, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1565459

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure, regression)

Filed by: rmaries [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=265589569&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/ZP-GjjuoQhi5LcjNtVYb6w/runs/0/artifacts/public/logs/live_backing.log


[task 2019-09-08T10:59:55.190Z] 10:59:55 INFO - TEST-START | devtools/client/webreplay/mochitest/browser_dbg_rr_breakpoints-06.js
[task 2019-09-08T11:02:55.788Z] 11:02:55 INFO - Longer timeout required, waiting longer... Remaining timeouts: 1
[task 2019-09-08T11:02:55.789Z] 11:02:55 INFO - Buffered messages finished
[task 2019-09-08T11:02:55.789Z] 11:02:55 INFO - TEST-UNEXPECTED-FAIL | devtools/client/webreplay/mochitest/browser_dbg_rr_breakpoints-06.js | Test timed out -
[task 2019-09-08T11:02:55.789Z] 11:02:55 INFO - Removing tab.
[task 2019-09-08T11:02:55.789Z] 11:02:55 INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2019-09-08T11:02:55.789Z] 11:02:55 INFO - Got event: 'TabClose' on [object XULElement].
[task 2019-09-08T11:02:55.789Z] 11:02:55 INFO - Tab removed and finished closing
[task 2019-09-08T11:02:55.789Z] 11:02:55 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-09-08T11:02:55.790Z] 11:02:55 INFO - TEST-UNEXPECTED-FAIL | devtools/client/webreplay/mochitest/browser_dbg_rr_breakpoints-06.js | A promise chain failed to handle a rejection: 'getEnvironment' active request packet to 'server0.conn5.child1/frame152' can't be sent as the connection just closed. - stack: (No stack available.)
[task 2019-09-08T11:02:55.790Z] 11:02:55 INFO - Rejection date: Sun Sep 08 2019 11:00:23 GMT+0000 (Greenwich Mean Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 263
[task 2019-09-08T11:02:55.790Z] 11:02:55 INFO - Stack trace:
[task 2019-09-08T11:02:55.790Z] 11:02:55 INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:263
[task 2019-09-08T11:02:55.790Z] 11:02:55 INFO - chrome://mochikit/content/browser-test.js:nextTest:912
[task 2019-09-08T11:02:55.790Z] 11:02:55 INFO - chrome://mochikit/content/browser-test.js:timeoutFn:1471
[task 2019-09-08T11:02:55.790Z] 11:02:55 INFO - setTimeout handlerchrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest_setTimeoutShim:686
[task 2019-09-08T11:02:55.790Z] 11:02:55 INFO - chrome://mochikit/content/browser-test.js:timeoutFn:1439
[task 2019-09-08T11:02:55.790Z] 11:02:55 INFO - setTimeout handler
chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest_setTimeoutShim:686
[task 2019-09-08T11:02:55.790Z] 11:02:55 INFO - chrome://mochikit/content/browser-test.js:timeoutFn:1439
[task 2019-09-08T11:02:55.790Z] 11:02:55 INFO - setTimeout handlerchrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest_setTimeoutShim:686
[task 2019-09-08T11:02:55.790Z] 11:02:55 INFO - chrome://mochikit/content/browser-test.js:timeoutFn:1439
[task 2019-09-08T11:02:55.790Z] 11:02:55 INFO - setTimeout handler
chrome://mochikit/content/browser-test.js:Tester_execTest:1418
[task 2019-09-08T11:02:55.790Z] 11:02:55 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1213
[task 2019-09-08T11:02:55.790Z] 11:02:55 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:805
[task 2019-09-08T11:02:55.790Z] 11:02:55 INFO - GECKO(1692) | JavaScript error: resource://testing-common/PromiseTestUtils.jsm, line 112: uncaught exception: Object
[task 2019-09-08T11:02:55.795Z] 11:02:55 INFO - Console message: [JavaScript Error: "uncaught exception: Object" {file: "resource://testing-common/PromiseTestUtils.jsm" line: 112}]
[task 2019-09-08T11:02:55.798Z] 11:02:55 INFO - GECKO(1692) | MEMORY STAT | vsize 7792MB | residentFast 473MB | heapAllocated 114MB
[task 2019-09-08T11:02:55.798Z] 11:02:55 INFO - TEST-OK | devtools/client/webreplay/mochitest/browser_dbg_rr_breakpoints-06.js | took 180635ms
[task 2019-09-08T11:02:55.833Z] 11:02:55 INFO - checking window state

Looks like a dupe of bug 1565459

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1565459
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.