Closed Bug 1579928 Opened 11 months ago Closed 10 months ago

Console evaluation should be shown based on their execution point

Categories

(Core Graveyard :: Web Replay, enhancement)

enhancement
Not set
normal

Tracking

(firefox71 fixed)

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: jlast, Assigned: jarilvalenciano)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Currently it is possible to rewind, pause, evaluate in the console.

The problem is that the messages are shown at the bottom. They should be shown relative to where you are paused. This should be easy to do given we already sort messages by execution point elsewhere.

Attachment #9101170 - Attachment is obsolete: true
Attachment #9101170 - Attachment is obsolete: false
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1e655610cc11
Reflect proper message order in the console for evaluations during replay r=jlast
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Assignee: nobody → jarilvalenciano
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.