Closed Bug 1579940 Opened 3 months ago Closed 2 months ago

Setup WNP for users coming from <70.0 and receiving the 70.0 release

Categories

(Release Engineering :: Release Requests, enhancement, major)

enhancement
Not set
major

Tracking

(firefox70blocking verified, firefox71 fixed)

VERIFIED FIXED
Tracking Status
firefox70 blocking verified
firefox71 --- fixed

People

(Reporter: erenaud, Unassigned)

References

()

Details

(Whiteboard: [releaseduty])

Attachments

(4 files)

Request is to have the product point to the /whatsnew page in the Firefox 70.0 release and show it (WNP).

  • en-GB needs to be included by activating the file manually en-US to show up in the URL implying that we need L10n (Peiying) to manually activate the file.

  • id - this needs to be added to the list of locales so they will receive the hard coded template with Firefox Lite content

  • There will be an additional hard coded template shown (w. English copy) to users geo-located in India. This issue in github is a dependency for that page - https://github.com/mozilla/bedrock/issues/7637 - We need to confirm if a locale needs to be identified for this or if en-US will suffice for this purpose.

  • New copy and design is forthcoming and the strings will be final, extracted on or before 9/18/2019

  • all users coming from <70.0 and receiving the 70.0 release should be show this page (if they are in the locales in which the content has been localized, the list that l10n will provide on Oct 11).

  • for locales w/o content, they should not be shown a page (does not default to en-US)

Eric, how is this going? Did the strings all land? What is there left to do?

Flags: needinfo?(erenaud)

The strings are good and out to Pontoon. Some late-breaking changes came in after the copy freeze. So rather than disturb that folks that had already localized the original content we are hard coding templates for Tier One with new strings.

Ultimately the process is the same though, we simply ask Flod to confirm the activated locales, including DE, FR, en-US, en-CA, en-GB for the hard coded templates, when the time comes (which is the Tuesday of RC week, iirc).

Flags: needinfo?(erenaud) → needinfo?(francesco.lodolo)

Note that Peiying is the point person and should be asked for the activated locales list.

Flags: needinfo?(francesco.lodolo) → needinfo?(pmo)

We still have a few days left to meet the due date of Oct 11. So far we have 39 locales completed (in addition to en-US):

  • be
  • cs
  • cy
  • da
  • de
  • dsb
  • en-CA
  • en-GB
  • es-AR
  • es-ES
  • es-MX
  • eu
  • fa
  • fr
  • fy-NL
  • gn
  • hr
  • hsb
  • hu
  • ia
  • id
  • it
  • ka
  • lt
  • nb-NO
  • nl
  • nn-NO
  • pl
  • pt-BR
  • ru
  • sk
  • sl
  • sq
  • sv-SE
  • tr
  • uk
  • vi
  • zh-CN
  • zh-TW
Flags: needinfo?(pmo)
Attached file WNP70screens.zip

Bogdan -

The final list of locales will be provided by Peiying tomorrow, 10/11.

If it does not include it (the list is pulled from Pontoon), en-US will need to be added to it.

Content:

en-US, en-CA, en-GB, de and fr will be shown conditional content, 2 versions of the page:

  • User is signed into a Firefox Account - they are shown the CTA to 'Sign in' (to Monitor) - (image is attached: WNP 70_Tier 1_Signed In.png)
  • User is NOT signed into a Firefox Account - they are shown the CTA to 'Sign Up for Monitor' in the hero section - (image is attached: WNP 70_Tier 1_Signed Out.png)

All other locales, except 'id', will shown content promoting tracking protection with the CTA to 'See what Firefox has blocked for me' that will open about:protections - the other CTAs lead to monitor.firefox.com and lockwise.firefox.com (which will soon be redirected to www.mozilla.org/firefox/lockwise)

There's no conditional state content in this version - see the image file 'WNP 70 Original.png'


The id locale, the Indonesian page, which will show content the same as that seen in the WNP 69 version, here - https://www.mozilla.org/id/firefox/69.0/whatsnew/all/ - this include the send-to-device widget allowing users to insert an email address to send a link to the app stores


Note:

  • The screenshots may diff in spacing/alignment a bit to the live webpages. For the most part this is okay. If there's anything seriously out of place, please advise us.
Flags: needinfo?(bogdan.maris)
Blocks: 1587967

Updated comment #4 with the latest list: 39 locales +en-US.

Noting that the WNP70 page is now live. QA can commence when ready.

https://www.mozilla.org/firefox/70.0/whatsnew/ - note that the URL will ultimately resolve to https://www.mozilla.org/firefox/70.0/whatsnew/all/

In order to accommodate a request to show a WNP to users in India (the location, not one of the locales, to promote Firefox Lite, in a hard coded template) we built a locale-specific router the bare whatsnew URL is a redirector, that redirects everyone to the */all/ URL. Note that the page is not yet live.

I don't have more locales to add to what's listed in comment #4.

Thanks Peiying!

Pushed by jlund@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f9209979c9bf
Setup WNP for users coming from <70.0 and receiving the 70.0 release, DONTBUILD NPOTB, r=aki, a=release
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

We managed to perform a round of test for WNP on relase-localtest and we found a couple of issues/discrepancies.

(In reply to Mihai Boldan, QA [:mboldan] from comment #14)

We managed to perform a round of test for WNP on relase-localtest and we found a couple of issues/discrepancies.

Eric or anyone else, can you help here with some input? All the tests marked with (FAILED NEW) don't respect the actual design.

Flags: needinfo?(bogdan.maris) → needinfo?(erenaud)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Marking as a blocker for now, though we'll see what Eric/Product teams think.

This bug is 100% a blocker. Thank you for flagging.

(In reply to Bogdan Maris [:bogdan_maris], Release Desktop QA from comment #15)

(In reply to Mihai Boldan, QA [:mboldan] from comment #14)

We managed to perform a round of test for WNP on relase-localtest and we found a couple of issues/discrepancies.

  • The old footer(black) is displayed for some builds;

Not all locales have caught up, thus the 'old' footer appears as the fallback. We're activating the locales that have updated, to date (11/15) and will look to see if we more can be activate prior to the 22nd

  • Language field from the bottom right side of the page is not displayed;

Apologies - en-US, en-GB, en-CA, DE and FR are hard coded templates and don't behave the same. We have a fix getting into place for this - https://github.com/mozilla/bedrock/commit/dadc6d24950daddbdb4402e4b5c4cb869172cd59 - that should hit by EOD Wednesday and I'll update back here when that happens/is live.

  • "See what Firefox has blocked for you" can't be opened in a new tab if the middle click is used. If using the right click and select 'Open in a new tab' option a new blank tab is displayed, with about:protections url populated.

This is expected behavior because it’s not a link - it's opening content in the browser itself. (Good observation, we didn't even think to convey this).

More detailed results can be found here: https://docs.google.com/spreadsheets/d/1Eo4OfeydNmJaWMyTVK_0ODyI4bku1L5rrtXpK_3XC0c/edit#gid=850719639 .

Eric or anyone else, can you help here with some input? All the tests marked with (FAILED NEW) don't respect the actual design.

I think these responses cover all the reported issues in the spreadsheet. Please let me know if not/questions remain.

Flags: needinfo?(erenaud) → needinfo?(bogdan.maris)

OK, so as I understand it the only truly blocking issue is going to be fixed in bedrock (https://github.com/mozilla/bedrock/commit/dadc6d24950daddbdb4402e4b5c4cb869172cd59) and there's nothing else that needs to land on mozilla-release. Is that correct?

Flags: needinfo?(erenaud)

(In reply to Eric Renaud [:erenaud] from comment #20)

  • The old footer(black) is displayed for some builds;

Not all locales have caught up, thus the 'old' footer appears as the fallback. We're activating the locales that have updated, to date (11/15) and will look to see if we more can be activate prior to the 22nd

I'm not following this bit.
en-US (purple footer): https://www-dev.allizom.org/en-US/firefox/70.0/whatsnew/all/
it (black footer): https://www-dev.allizom.org/it/firefox/70.0/whatsnew/all/

As far as I understand, Italian has all the needed strings, and it's going to be enabled for 70 release. Where's the choice between footers made?

Also, unless I'm looking at the wrong URL, tier1 locales are redirected to en-US (or another locale in your accept-languages) in production?
https://www.mozilla.org/de/firefox/70.0/whatsnew/
https://www.mozilla.org/fr/firefox/70.0/whatsnew/

(In reply to Francesco Lodolo [:flod] from comment #22)

(In reply to Eric Renaud [:erenaud] from comment #20)

  • The old footer(black) is displayed for some builds;

Not all locales have caught up, thus the 'old' footer appears as the fallback. We're activating the locales that have updated, to date (11/15) and will look to see if we more can be activate prior to the 22nd

I'm not following this bit.
en-US (purple footer): https://www-dev.allizom.org/en-US/firefox/70.0/whatsnew/all/
it (black footer): https://www-dev.allizom.org/it/firefox/70.0/whatsnew/all/

As far as I understand, Italian has all the needed strings, and it's going to be enabled for 70 release. Where's the choice between footers made?

Found the code. So, this is currently just English and German.

These hard coded templates are live (locales activated) in which the lang selector is now visible.

https://www.mozilla.org/de/firefox/70.0/whatsnew/all/
https://www.mozilla.org/fr/firefox/70.0/whatsnew/all/

Yes - Craig Cook talked to Peiying and we think we have enough coverage already to make the footer global - so we'll do that prior to Oct 22.

Flags: needinfo?(erenaud)

The navigation file also reaches above 90% and should be considered for production push: https://l10n.mozilla-community.org/langchecker/?locale=all&website=0&file=navigation.lang. I suggest to have the new nav and footer look at the same time.

The /all/ should be appended with the desired locale when testing to avoid that redirection. It’s a bug of sorts, but not one that requires fixing for launch.

Users shown the page (active locale) will be shown content based on location (indicated in their header) and based on their chosen locale.

I just tested with DE as my chosen language, using the base URL https://www.mozilla.org/de/firefox/70.0/whatsnew/ and I’m redirected to https://www.mozilla.org/de/firefox/69.0/whatsnew/all/ - which is the expected behavior.

(In reply to Eric Renaud [:erenaud] from comment #26)

Users shown the page (active locale) will be shown content based on location (indicated in their header) and based on their chosen locale.

I just tested with DE as my chosen language, using the base URL https://www.mozilla.org/de/firefox/70.0/whatsnew/ and I’m redirected to https://www.mozilla.org/de/firefox/69.0/whatsnew/all/ - which is the expected behavior.

I disagree the behavior I described in comment 22 was expected. Not that it matters, because now it seems to be working (if I open the /de whatsnew, I stay there, independently from my accept-languages), I assume because of this.

(In reply to Francesco Lodolo [:flod] from comment #27)

(In reply to Eric Renaud [:erenaud] from comment #26)

Users shown the page (active locale) will be shown content based on location (indicated in their header) and based on their chosen locale.

I just tested with DE as my chosen language, using the base URL https://www.mozilla.org/de/firefox/70.0/whatsnew/ and I’m redirected to https://www.mozilla.org/de/firefox/69.0/whatsnew/all/ - which is the expected behavior.

I disagree the behavior I described in comment 22 was expected. Not that it matters, because now it seems to be working (if I open the /de whatsnew, I stay there, independently from my accept-languages), I assume because of this.

Never mind, I tested the URL with the /all at the end. As :jcristau pointed out on IRC, if you visit the URL without the /all part, you get into a bunch of redirects and lose the locale requested in the URL. Far from a blocker, but I still don't think that's ideal.

Jordan, is there anything left to do here for 70 launch? We have QA signoff now.

Flags: needinfo?(jlund)

(In reply to Liz Henry (:lizzard) from comment #29)

Jordan, is there anything left to do here for 70 launch? We have QA signoff now.

not that I'm aware of so long as the locales have not changed :)

Status: REOPENED → RESOLVED
Closed: 2 months ago2 months ago
Flags: needinfo?(jlund)
Resolution: --- → FIXED

Let's call this fixed then! Thanks.

Since we already signed off this on all Fx70 release channels I am gonna remove the needinfo on me and mark it as verified.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.