Closed Bug 1580007 Opened 2 years ago Closed 2 years ago

Composite Unicode (Chinese) under Yahoo Mail Results in Monster or ? Char

Categories

(Thunderbird :: Untriaged, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1435903

People

(Reporter: r_chui, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Write (/Reply) Mail with Chinese Char using yahoo mail (smtp.mail.yahoo.com)
Send Mail

Actual results:

  1. The Sent Folder (for yahoo sent) 1st (some times) Got ??? instead of Chinese char
  2. OK, Sent Folder ^^ Display Chinese Char Correctly
  3. BUT E-Mail Receivers Still Got All "????" for Chinese chars
    (No Problem for Subject, Chinese Chars display OK)
  4. Similar Bug seems applied to smtp.aol.com

  1. Yet Composite & Send E-Mail with Other smtp mail server(s) OK, like smtp.mail.com, mail.smtp2go.com
  2. Composite with K-9 Mail on Smartphone OK for Yahoo Chinese

Expected results:

SUPPORT UNICODE (Chinese, E Asian) Char For Most, at least Popular SMTP Servers like Yahoo, AOL

腔,

人90;时髦
----- Above OK, Below Fail ---
???,

?????90;??????

Yes, we know that Yahoo destroys e-mail, please read this.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1435903
You need to log in before you can comment on or make changes to this bug.