Closed Bug 1580239 Opened 1 year ago Closed 5 months ago

Fix usage of nsIDocShellTreeItem in nsDocShell::EnsureContentViewer

Categories

(Core :: DOM: Navigation, defect, P2)

defect

Tracking

()

RESOLVED WONTFIX
Fission Milestone M6b

People

(Reporter: djvj, Assigned: djvj)

References

(Blocks 1 open bug)

Details

(Whiteboard: [rm-docshell-tree-item:hard])

Attachments

(1 file)

https://searchfox.org/mozilla-central/source/docshell/base/nsDocShell.cpp#6875

This should be a straightforward fix. The parent tree item is retrieved and checked for existence to determine top-ness of the current docshell. This should be changed to use the BrowsingContext instead.

Fission Milestone: --- → M5
Priority: -- → P2
Whiteboard: [rm-docshell-tree-item:simple]
Fission Milestone: M5 → Future

Kannan says replacing nsIDocShellTreeItem calls should block enabling Fission in Nightly (M6).

Fission Milestone: Future → M6
Assignee: nobody → kvijayan
Whiteboard: [rm-docshell-tree-item:simple] → [rm-docshell-tree-item:hard]

Auditing whether this use of nsIDocShellTreeItem breaks when Fission is enabled blocks Fission Nightly.

Fission Milestone: M6 → M6b

This is implementing intended behaviour for inheriting properties of initial about:blank documents, so we don't need to change anything here for Fission.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.