want a remove dup mail feature

RESOLVED DUPLICATE of bug 9413

Status

enhancement
P5
normal
RESOLVED DUPLICATE of bug 9413
17 years ago
13 years ago

People

(Reporter: ftang, Assigned: Bienvenu)

Tracking

({helpwanted})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

17 years ago
I always have several dup message in my mail box when the message is sent to me
and a mailing list. It is really not necessary for me to see several mail which
contan exactuly the same information in my mail box. 

I want an option that we will make sure there are only one message in the same
mail folder if the Message-ID, Date, Subject and From are exactly the same
Assignee

Comment 1

17 years ago
helpwanted, -> nobody, correcting component to front end. That code can all be
written in js.
Assignee: bienvenu → nobody
Severity: normal → enhancement
Component: Mail Database → Mail Window Front End
Keywords: helpwanted
OS: Windows XP → All
Priority: -- → P5
Hardware: PC → All
Target Milestone: --- → Future

Comment 2

17 years ago
I've wanted this feature for-ever.  Please consider for Buffy.
Keywords: nsbeta1

Comment 3

17 years ago
I think we already have one or two existing reports about this.  Will check.
QA Contact: gayatri → laurel

Comment 4

17 years ago
*** Bug 60876 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
This looks like a dup of bug 87853. Even the reporter is the same :-)

Updated

17 years ago
Blocks: 66425

Comment 6

16 years ago
adt: nsbeta1-
Keywords: nsbeta1nsbeta1-

Comment 7

16 years ago
Bug 87853 actually is the very same bug... and it's kinda crazy this bug 60876
is a duplicate of this one: it was files 2 years in advance 0=)

Comment 8

15 years ago
*** Bug 87853 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
I want this type of tool, too.

I had a problem with Mozilla 1.7.2 in that
when I tried to interrupt "Run filter" operation
on a large folder, the "Stop" didn't seem to work well
and left a running thread and when I didn't realize this,
mozilla seemed to have spawned another thread when I hit
"Run Now" again, and as a result, I had duplicate e-mails
in certain folders. This problem was repeated a few times
and now I have three copies of the same file in one folder
and two copies of the same file in another folder. Ouch.

Comment 10

15 years ago
How would it decide which one to keep, where they're not identical in other
respects?

Also for sent/received duplicates, which aren't quite the same as no Message-ID
is stored for a sent copy.
Product: Browser → Seamonkey
Assignee

Updated

15 years ago
Assignee: nobody → bienvenu

Comment 11

14 years ago
*** Bug 298299 has been marked as a duplicate of this bug. ***

Comment 12

14 years ago
Suggested criterion for "duplicate": same date, same contents, same
senders/recievers? Use a MD5 hash of all of the above, and an associative lookup
table to spot matching hash value pairs, and then double-check for actual
equivalence before deleting, just to be safe.



Comment 13

14 years ago
I let it run to completion, and then exited and restarted Thunderbird. And then
it started to do it all again!  Aaaaaargh! 

Comment 14

14 years ago
Whoops: previous comment related to the repeated re-downloading of everything
bug, not this bug.

Comment 15

14 years ago
...the bug related to perpetual re-downloading, by the way, is bug 295473.

Comment 16

14 years ago
...er, no it's not, it's bug 303661. That's
https://bugzilla.mozilla.org/show_bug.cgi?id=303661

Oh dear. Coffee time, reset brain.

Comment 17

14 years ago
Some wishful notes:

- I also want the option to have this run automatically whenever I downloaded a new batch of messages
- I also want the option to configure it so that the message ID and/or date may defer, but if everything else is the same than it's still the same.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 9413
You need to log in before you can comment on or make changes to this bug.