Closed Bug 1580323 Opened 7 months ago Closed 3 months ago

Intermittent devtools/client/debugger/test/mochitest/browser_dbg-quick-open.js | Test timed out -

Categories

(DevTools :: Debugger, defect, P5)

defect

Tracking

(firefox-esr68 unaffected, firefox71 wontfix, firefox72 fixed)

RESOLVED FIXED
Firefox 72
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- wontfix
firefox72 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: sorin.davidoi)

References

(Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell disabled])

Attachments

(2 files)

Filed by: rmaries [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=265979899&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/UZg1CciHRP2LdVtnlHmJqg/runs/0/artifacts/public/logs/live_backing.log


[task 2019-09-10T19:43:48.697Z] 19:43:48 INFO - TEST-START | devtools/client/debugger/test/mochitest/browser_dbg-quick-open.js
[task 2019-09-10T19:45:19.151Z] 19:45:19 INFO - TEST-PASS | devtools/client/debugger/test/mochitest/browser_dbg-quick-open.js | quickOpen enabled -
[task 2019-09-10T19:45:19.151Z] 19:45:19 INFO - Buffered messages logged at 19:43:55
[task 2019-09-10T19:45:19.152Z] 19:45:19 INFO - Waiting for state change: selected source
[task 2019-09-10T19:45:19.153Z] 19:45:19 INFO - Buffered messages finished
[task 2019-09-10T19:45:19.153Z] 19:45:19 INFO - TEST-UNEXPECTED-FAIL | devtools/client/debugger/test/mochitest/browser_dbg-quick-open.js | Test timed out -
[task 2019-09-10T19:45:19.181Z] 19:45:19 INFO - Removing tab.
[task 2019-09-10T19:45:19.181Z] 19:45:19 INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2019-09-10T19:45:19.222Z] 19:45:19 INFO - Got event: 'TabClose' on [object XULElement].
[task 2019-09-10T19:45:19.263Z] 19:45:19 INFO - Tab removed and finished closing
[task 2019-09-10T19:45:19.319Z] 19:45:19 INFO - GECKO(1525) | JavaScript error: resource://testing-common/PromiseTestUtils.jsm, line 112: uncaught exception: Object
[task 2019-09-10T19:45:19.320Z] 19:45:19 INFO - Console message: [JavaScript Error: "uncaught exception: Object" {file: "resource://testing-common/PromiseTestUtils.jsm" line: 112}]
[task 2019-09-10T19:45:19.321Z] 19:45:19 INFO - GECKO(1525) | MEMORY STAT | vsize 20976901MB | residentFast 2945MB
[task 2019-09-10T19:45:19.321Z] 19:45:19 INFO - TEST-OK | devtools/client/debugger/test/mochitest/browser_dbg-quick-open.js | took 90623ms
[task 2019-09-10T19:45:19.382Z] 19:45:19 INFO - checking window state

Keywords: leave-open
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
Pushed by ccoroiu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a1cb4908e275
Disable browser_dbg-quick-open.js on mac and linux debug for frequent failures. r=egao

Increase stability by replacing the arbitrary timeouts with waiting for the DOM.

Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/71b7b4ca7993
test(browser_dbg-quick-open): Remove timeouts

I think I can be unassigned since I've fixed the regression I've introduced (the big spike in October): https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2019-09-28&endday=2019-11-26&tree=trunk&bug=1580323 The rest of the failures are unrelated to my changes.

Flags: needinfo?(jlaster)
Flags: needinfo?(jlaster)
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
You need to log in before you can comment on or make changes to this bug.