Closed Bug 1580505 Opened 11 months ago Closed 11 months ago

The "Edit" and "Create New Login" mode are not dismissed after clicking the "Save/Save Changes" button if the "about:logins" tab is moved to a new window

Categories

(Firefox :: about:logins, defect, P1)

70 Branch
Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- disabled
firefox70 --- verified
firefox71 --- verified

People

(Reporter: cmuntean, Assigned: jaws)

References

Details

(Whiteboard: [passwords:management] [skyline])

Attachments

(2 files)

[Notes]:

  • The changes are also not visible, only after the page is refreshed.
  • If the page is refreshed after the "about:logins" tab was moved, the issue is no longer reproducible.

[Affected Versions]:

  • Nightly 71.0a1
  • Beta 70.0b4

[Affected Platforms]

  • All Windows
  • All Mac
  • All Linux

[Prerequisites]:

  • Have at least one tab opened.

[Steps to reproduce]:

  1. Open the latest Nightly browser and navigate to "about:logins".
  2. Move the "about:logins" tab to a new window.
  3. Click the "Create New Login" button.
  4. Enter valid credentials in the required fields.
  5. Click the "Save" button and observe the behavior.

[Expected results]:

  • The "Create New Login" mode is dismissed and the login is successfully created.

[Actual results]:

  • Nothing happens. If the "Save" button is clicked again the "An entry for [website_doamin] with that username already exists" error message is displayed.

[Additional Notes]:

  • The issue is also reproducible in "Edit" mode. If the edit mode of a saved login is opened and the credentials are edited, nothing happens if the "Save" button is clicked. However, if the page is refreshed, the login is correctly updated with the changes that were made.
  • Attached a screen recording with the issue.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Priority: -- → P1

If a docshell is swapped, we will need to update the targets. Any stale targets will get cleaned up by the subscriber iterator.

Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2d623623f05d
Add the message target to the subscribers set anytime we receive a message. r=MattN
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

I have verified this issue on the latest Nightly 71.0a1 (Build ID: 20190918100042) (64-bit) on Windows 10, MacOS 10.14 and Ubuntu 16.04 x64.

  • The saved login is added to the "Login List" and the "Create New Login" mode is replaced with the "Login Item" mode when click on the "Save" button if the "about:logins" page is moved to new window.
  • The changes are saved and updated and the "Edit" mode is dismissed when click on the "Save Changes" button if the "about:logins" page is moved to new window.
Status: RESOLVED → VERIFIED

I have verified this issue on the Firefox Beta 70.0b9 (Build ID: 20190923154733) (64-bit) on Windows 7, MacOS 10.14 and Arch 4.14.

  • The saved login is added to the "Login List" and the "Create New Login" mode is replaced with the "Login Item" mode when click on the "Save" button if the "about:logins" page is moved to a new window.
  • The changes are saved and updated and the "Edit" mode is dismissed when clicking on the "Save Changes" button if the "about:logins" page is moved to a new window.
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla71 → Firefox 71
Version: 71 Branch → 70 Branch
You need to log in before you can comment on or make changes to this bug.