Closed Bug 1580512 Opened 5 months ago Closed 5 months ago

input[type="number"] in prefs not tall enough

Categories

(Thunderbird :: Theme, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 71.0

People

(Reporter: Paenglab, Assigned: Paenglab)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files, 3 obsolete files)

The border around the input[type="number"] isn't outside the spinbuttons.

Attached patch 1580512-input-type-number.patch (obsolete) — Splinter Review

Unfortunately we need different paddings per platform.

Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9092104 - Flags: review?(alessandro)
Attached image Screenshot from 2019-09-11 09-04-49.png (obsolete) —

Linux on HiDPI monitor

Comment on attachment 9092104 [details] [diff] [review]
1580512-input-type-number.patch

Review of attachment 9092104 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good on macOS but on Linux it should be 6px as well.
I don't know if it's due to the fact that I'm using a HiDPI monitor with large font.

Anyway, after this quick fix it's a r+ for me.
I don't have the ability to check it on Windows tho.

Thanks for taking care of this.

::: mail/themes/linux/mail/preferences/preferences.css
@@ +24,5 @@
>    margin-bottom: 11px;
>  }
>  
> +html|input[type="number"] {
> +  padding: 5px 1px;

This should be 6px as well (see screenshot)
Attachment #9092104 - Flags: review?(alessandro) → review+
Attached patch 1580512-input-type-number.patch (obsolete) — Splinter Review

Yes, 6px looks better.

Attachment #9092104 - Attachment is obsolete: true
Attachment #9092118 - Flags: review+
Keywords: checkin-needed

Heads up, the problem with the field is not limited to the preferences panel.

Attachment #9092114 - Attachment is obsolete: true

Found bug 1577602 which seems to be the reason for this issue. I'm looking for a different approach.

Keywords: checkin-needed

This reverts the change on the ::-moz-number-spin-box from bug 1577602.

Attachment #9092118 - Attachment is obsolete: true
Attachment #9092186 - Flags: review?(alessandro)
Comment on attachment 9092186 [details] [diff] [review]
1580512-input-type-number.patch

Review of attachment 9092186 [details] [diff] [review]:
-----------------------------------------------------------------

This perfectly fixes the problem everywhere. 
Great work!
Attachment #9092186 - Flags: review?(alessandro) → review+
Keywords: regression
Regressed by: 1577602
Keywords: checkin-needed

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/7d960e3a15ab
Revert bug 1577602 on the ::-moz-number-spin-box to make the input[type="number"] box taller. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 71.0
You need to log in before you can comment on or make changes to this bug.