Closed Bug 1580538 Opened 5 months ago Closed 5 months ago

Make OverflowableToolbar work without overflow:hidden (drag-select from unfocused state and click-selects-all are broken in megabar due to reframing)

Categories

(Firefox :: Toolbars and Customization, defect, P1)

defect
Points:
3

Tracking

()

RESOLVED FIXED
Firefox 71
Iteration:
71.2 - Sept 16 - 29
Tracking Status
firefox71 --- fixed

People

(Reporter: dao, Assigned: dao)

References

(Blocks 3 open bugs)

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1577472 +++

Looks like bug 1577472 didn't actually fix this although I think it was a step in the right direction.

Assignee: nobody → dao+bmo
Iteration: --- → 71.2 - Sept 16 - 29

So I had fixed the original cause in bug 1577472, then broke it again updating this rule because changing overflow reconstructs frames: https://searchfox.org/mozilla-central/rev/053579099d936e26393ac10b809b14fb5841c0f0/browser/base/content/browser.css#241-243

I'll see if I can make OverflowableToolbar not use the overflow event so we can get rid of overflow: hidden.

Component: Address Bar → Toolbars and Customization
Blocks: 1577541
Duplicate of this bug: 1578291

(In reply to Dão Gottwald [::dao] from comment #2)

I'll see if I can make OverflowableToolbar not use the overflow event so we can get rid of overflow: hidden.

It should be possible to determine from the event whether the overflow event comes from the location bar or somewhere else...

(In reply to :Gijs (he/him) from comment #4)

(In reply to Dão Gottwald [::dao] from comment #2)

I'll see if I can make OverflowableToolbar not use the overflow event so we can get rid of overflow: hidden.

It should be possible to determine from the event whether the overflow event comes from the location bar or somewhere else...

That doesn't help. The problem is that the urlbar overflows the toolbar vertically, and overflow:hidden would hide that part. I added :not([urlbar-breakout-extend]) in https://searchfox.org/mozilla-central/rev/053579099d936e26393ac10b809b14fb5841c0f0/browser/base/content/browser.css#241-243 to fix that but that causes this bug.

Anyway, I've put together a prototype patch and it seems that OverflowableToolbar can actually work without overflow: hidden and the overflow event.

Blocks: 1528656
Blocks: 1527577
Blocks: 1421021
Summary: Drag-select from unfocused state and click-selects-all are broken in megabar → Make OverflowableToolbar work without overflow:hidden (drag-select from unfocused state and click-selects-all are broken in megabar due to reframing)
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/517c9efa9592
Make OverflowableToolbar work without overflow:hidden. r=Gijs
Depends on: 1582797
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Depends on: 1583148
Regressions: 1582943
Regressions: 1582906
No longer depends on: 1583148
Regressions: 1583148
Blocks: 1571236
Regressions: 1584101
Blocks: 1536312
Depends on: 1584101
No longer depends on: 1584101
Regressions: 1607160
Regressions: 1607810
Regressions: 1601706
Regressions: 1610497
Regressions: 1611689
You need to log in before you can comment on or make changes to this bug.