Closed Bug 15806 Opened 20 years ago Closed 6 months ago

[Voting] Provide vote summary statistics

Categories

(Bugzilla :: Extensions, enhancement, P4)

enhancement

Tracking

()

RESOLVED WONTFIX

People

(Reporter: michael.j.lowe, Unassigned)

References

Details

Attachments

(1 file)

Provide page for 10 most popular bugs for each product, as well as means to sort
a bugzilla query by the number of votes.
This would be nicely handleable as an application of bug #12282, general summary
reports.
The ability to sort on the number of votes is already present, check out "change
 columns".
Yes, but along with many other fields it is not available in the "Sort By" combo
in the form at:
http://bugzilla.mozilla.org/show_bug.cgi?id=15806.
You can now query by number of votes, which fixes half of this request.
You can sort by clicking of the bug list column title hyperlink, but there's no
quick link on the query screen.  I agree that there should be.
Status: NEW → ASSIGNED
*** Bug 28571 has been marked as a duplicate of this bug. ***
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara
Status: ASSIGNED → NEW
Adding default QA contact to all open Webtools/Bugzilla bugs lacking one.
Sorry for the spam.
QA Contact: matty
Target Milestone: --- → Future
Moving to new Bugzilla product ...
Assignee: tara → endico
Component: Bugzilla → Query/Bug List
Product: Webtools → Bugzilla
Version: other → unspecified
This patch is against 2.14, and is already superceded by templatisation, but
may be useful for older systems, or as a base for later work.

This adds a 'topvotes' parameter to showvotes.cgi, which, by default, will
generate tables for each product with voting enabled, showing the top 10 voted
for bugs. The 'only_open' parameter can be used to restrict the tables to open
bugs. Individual products can be specifed as well using any number of 
'product=XXX' parameters.
Keywords: patch, review
Attachment #65621 - Flags: review?
Comment on attachment 65621 [details] [diff] [review]
showvotes.cgi patch to add Top 10 most-voted-for bug tables for products

needs updating to tip + templating before any review needed
Attachment #65621 - Flags: review? → review-
check out http://bugs.kde.org/ for ideas
Re: comment#12, the KDE bugzilla has lots of nice stats, but I can't see any
specific enhancements to the voting reporting that CVS Bugzilla (or even recent
releases) cannot do out of the box already  -- am I missing them?
*** Bug 214714 has been marked as a duplicate of this bug. ***
Assignee: endico → nobody
QA Contact: mattyt-bugzilla → default-qa
Target Milestone: Future → ---
Priority: P3 → P4
Assignee: nobody → query-and-buglist
Summary: Provide vote summary statistics → [Voting] Provide vote summary statistics
(In reply to Terry Weissman from comment #4)
> You can now query by number of votes, which fixes half of this request.

Sorry if I am being dense, how can you search based on # of votes?
Display the column votes in search results: http://blogs.gnome.org/aklapper/2013/06/21/bugzillatips-changecolumns/ and sort by it, and combine it with the Advanced Search to show only tickets with Votes > X?
Assignee: query-and-buglist → extensions
Component: Query/Bug List → Extensions

The voting functionality will be replaced with emoji comment reactions in the near future.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.