Closed Bug 158067 Opened 17 years ago Closed 17 years ago

MOZ mail (Messenger) does not accept more than 4120 bytes from X11 cut&paste buffer

Categories

(MailNews Core :: Composition, defect, critical)

x86
Linux
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 56219

People

(Reporter: primorec, Unassigned)

References

()

Details

Can I reproduce it ?  YES, any time

STEPS TO reproduce it:

A) create with "gvim" an ASCII file with more than 4120 characters
   (lets say 10000 characters). The resulting file will be more than 
    one screen long. Keep the file opened on the screen
B) open mozilla e-mail and click on "compose" button
C) click with the mouse into "body" part of the newly
   created window
D) select (mark, highlight) with "LEFT" mouse button more
   than 4120 characters in the "gvim" window
E) move the mouse into the "body" field of the e-mail compose
   window
F) click with the "MIDDLE" mouse button to paste the text
   from "gvim" into e-mail compose window

ACTUAL RESULT: nothing happens
WHAT SHOULD HAPPEN ? user should be able to paste the X11
                     buffer into the e-mail compose window

G) repeat the above procedure but select LESS than 4120 characters

RESULT: everything is nice and dandy (a.k.a.  WORKS OK !!)

ADDITIONAL NOTE: NS4.7x Messenger works fine
with, at least, 800K characters. I did not test it with more than 0.8MB.

my system: RH6.2 kernel 2.2.14-5.0
MOZILLA:
Mozilla 1.1a
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1a) Gecko/20020610
changing component to MAIL/NEWS

or, perhaps, I should change it to COMPOSER ??
Severity: normal → critical
Component: Editor: Composer → Composition
Product: Browser → MailNews
Methinks it's dupe of bug 56219. Correct me if I'm wrong.

*** This bug has been marked as a duplicate of 56219 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
yes   you are right...  I think that the ORIGINAL bug 56219 should be
marked CRITICAL !!!
vrfy dupe.

Igor, please read the following to learn what we call "critical".

http://bugzilla.mozilla.org/bug_status.html#severity
Status: RESOLVED → VERIFIED
Yes, I clicked on the link and I found there the following:

Major
major loss of function 

Minor
minor loss of function, or other problem where easy workaround is present 

Trivial
cosmetic problem like


I could not find there the definition of "Normal". Right now this bug is defined
as "Normal". Yes, I do agree with you, it is NOT critical bug. It should be
marked "Major", because is is a major loss of function (aka.. you can NOT
paste more than 4K of data into the body of the e-mail). I am using 
the e-mail a lot and I do cut and paste a big chunkes of ASCII text into the
e-mail.  Because of the limit of 4KB I am NOT using mozilla's e-mail
as my everyday e-mail client. I am still using NS4.7x Messanger.
So, this is a major loss of function and the bug should be marked "Major"
and not "Normal"
reassign in case bugs are reopened
Assignee: syd → composer
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.