Closed Bug 1580792 Opened Last month Closed 26 days ago

"Paste and Go" no longer searches for the clipboard term if strings are in the address bar

Categories

(Firefox :: Address Bar, defect, P1)

defect
Points:
3

Tracking

()

VERIFIED FIXED
Firefox 71
Iteration:
71.2 - Sept 16 - 29
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified
firefox71 --- verified

People

(Reporter: mcoman, Assigned: mak)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image rec of the issue1.gif

[Affected versions]:

  • Firefox Beta 70.0b5 - Build ID: 20190909162732
  • Firefox Nightly 71.0a1 - Build ID: 20190912094122

[Affected Platforms]:

  • All Windows
  • All Linux
  • All Mac

[Prerequisites]:

  • Have the latest Firefox Beta or Nightly installed.
  • Have any text copied to clipboard.

[Steps to reproduce]:

  1. Open the browser with the profile from prerequisites.
  2. Type a text string different from the one from prerequisites in the "Address Bar".
  3. Right-click in the "Address Bar" and select the "Paste & Go" option.
  4. Observe the behavior.

[Expected result]:

  • A search is performed for the string copied to clipboard.

[Actual result]:

  • The search is performed for the string typed at step 2.

[Regression Window]:

  • Considering the fact that this issue is not reproducible on latest Firefox Release (69.0), using the "mozregression" tool I have managed to find the following regression:

Last good revision: 47e72c204ef61c34509e430c0976f4db680e384a
First bad revision: 580d975db59096011e93150a04856a15b9e8812d
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=47e72c204ef61c34509e430c0976f4db680e384a&tochange=580d975db59096011e93150a04856a15b9e8812d

From the pushlog, it seems that bug 1551598 caused this issue.

[Notes]:

  • This issue is still reproducible even if you paste a URL in the "Address Bar" using the "Paste & Go" option
  • Attached a screen recording of the issue.
Blocks: megabar
Blocks: 1580791

I don't know what's going on here, haven't had time to take a closer look yet. Marco, Mike mentioned to me you might be interested in picking this up. Otherwise I'll investigate when I get a chance.

Flags: needinfo?(mak77)
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Flags: needinfo?(mak77)
Priority: -- → P1
Iteration: --- → 71.2 - Sept 16 - 29
Points: --- → 3

From a first analysis, apparently now we close the panel after the paste operation, closing the panel makes so that .selectedResult returns null.
What actually happens now is:
paste
handleCommand asks for .selectedResult, since it can find a selectedResult it calls pickResults
we close the panel

I think in the old world we were closing the popup sooner, and that ended up clearing the selection, so handleCommand didn't pick the selected result. I'm still looking where/how we were doing that though.

Ah the reason is simple, on right click (context menu) we used to close the urlbar panel.

Autocomplete used to close the urlbar panel when opening the contextual menu.

No longer blocks: 1580791
Duplicate of this bug: 1580791
Blocks: 1577541
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/1b3d42760974
"Paste and Go" no longer searches for the clipboard term if strings are in the address bar. r=dao
Status: ASSIGNED → RESOLVED
Closed: 26 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Comment on attachment 9093838 [details]
Bug 1580792 - "Paste and Go" no longer searches for the clipboard term if strings are in the address bar. r=dao

Beta/Release Uplift Approval Request

  • User impact if declined: Paste and go feature of the urlbar contextual menu doesn't work properly
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: see comment 0
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): it's a simple one-liner patch closing the urlbar panel
  • String changes made/needed:
Attachment #9093838 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Comment on attachment 9093838 [details]
Bug 1580792 - "Paste and Go" no longer searches for the clipboard term if strings are in the address bar. r=dao

Low risk, covered by tests, fixes a P1 70 regression, uplift approved for 70 beta 9, thanks.

Attachment #9093838 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I have verified that this issue is no longer reproducible with the latest Firefox Nightly (71.0a1 Build ID - 20190923215658) and latest Firefox Beta (70.0b9 Build ID - 20190923154733) installed, on Windows 10 x64, Arch Linux and Mac 10.14.5. Now, "Paste and Go" searches for the clipboard term, even if strings are already in the address bar.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.