Closed Bug 1580883 Opened Last month Closed 26 days ago

nsJSEnvironment uses a mix of NSPR and TimeStamp time APIs

Categories

(Core :: DOM: Core & HTML, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: jonco, Assigned: jonco)

References

Details

Attachments

(4 files)

It would probably be better to change this to use TimeStamp/TimeDuration where possible.

Great. I worked on some patches for this a few years ago, but I never got around to finishing them.

Duplicate of this bug: 879404

(In reply to Andrew McCreight [:mccr8] from comment #5)
Cool. One question I had was should we be using TimeStamp::NowUnfuzzed() here? I don't think any of these timeouts are be observable by content, but maybe the greater resolution is unnecessary here.

Pushed by jcoppeard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1d574f9c4457
Use TimeStamp/TimeDuration APIs instead of PRTime/PR_Now() in nsJSEnvironment.cpp r=mccr8
https://hg.mozilla.org/integration/autoland/rev/2139d06ac9d2
Use TimeDuration for constants in nsJSEnvironment.cpp r=mccr8
https://hg.mozilla.org/integration/autoland/rev/c23405648344
Use TimeDuration for remaining global in nsJSEnvironment.cpp r=mccr8
https://hg.mozilla.org/integration/autoland/rev/94c4e9a25f19
Use TimeDuration for CycleCollectorStats members r=mccr8
You need to log in before you can comment on or make changes to this bug.