Closed Bug 1581066 Opened Last month Closed Last month

Fake zoomed in section in Graphs view

Categories

(Tree Management :: Perfherder, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: igoldan, Assigned: sclements)

References

(Regression)

Details

Attachments

(3 files)

STR

  1. Click on the graphs hyperlink from a Talos/Raptor alert (example graph).
  2. Zoom into an area using the upper graph.
  3. Toggle one of the signatures.

Expected:
The gray zoomed in section from upper graph should remain the same.

What we get instead:
When we toggle off one of the signatures, the upper graph shows the gray zoomed section as applied on the whole graph. When we toggle back on that signature, the upper graph correctly shows that section, but it breaks the Y-axis legend from the bottom graph.
The time ranges from both graphs are identical, when instead the bottom one should have been narrower.

Attachment #9092608 - Attachment description: Correct area, when both signatures are toggled on → Correct area when both signatures are toggled on
Attachment #9092609 - Attachment description: Bad aread when one signature is toggled off → Incorrect area when one signature is toggled off
Regressed by: 1519995

What's happening here is the zoom is being reset anytime the test data changes. When a checkbox is toggled, it's visibility attribute is changed which then triggers an update to the graphs and resets the zoom. I've changed it so it doesn't reset the zoom if its only a visibility update.

Assignee: nobody → sclements
Status: NEW → ASSIGNED
Priority: -- → P1

Merged and pushed to production.

Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.