Folder settings not stored when using multiple mail accounts

RESOLVED FIXED

Status

SeaMonkey
MailNews: Account Configuration
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: Manuel Silva, Assigned: racham)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

When using Mozilla Mail with more than one mail account, second, third and so on
mail accounts folder configuration isn't working properly. Checking the file
prefs.js everything seems to be recorded ok (comparing the first configured
account with the other ones) but, using the front-end, the information isn't used.

Reproducible: Always
Steps to Reproduce:
1. Create one mail account on Mozilla Mail and configure it (Edit -> Mail &
Newsgroups account settings);
2. Check, on the same menu, if everything was recorded correctly;
3. Repeat step one and 2 with deleting the first account created;
4. "Copies & Folders" tag isn't recorded properly.

Actual Results:  "Copies & Folders" from the second and above accounts isn't
recorded properly which doesn't allow the record of Drafts or Sent messages.

Expected Results:  Store and use all configuration information correctly.
(Reporter)

Comment 1

16 years ago
Created attachment 91799 [details]
Screenshot from the bug

After configuring the account, even without closing Mozilla Mail, here's the
result when backing to the menu option... It seems that nothing was recorded.
(Reporter)

Comment 2

16 years ago
This problem can be fixed by deleting prefs.js and localstore.rdf created by
previous versions of Mozilla/Netscape.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 3

16 years ago
Is the second account the same as the first account? In other words, are you
entering the same account information for both accounts?
(Reporter)

Comment 4

16 years ago
Dear Ninoschka Baca,
the accounts were different, with different servers, different usernames and
different account names so there wasn't any mix of data.
The problem was related with previous versions of Mozilla/Netscape. I had some
troubles before configuring my accounts and importing my messages from Outlook
Express (too many messages, I suppose) and these tries weren't deleted from
localstore.rdf automatically. That's why the conflict occurred, because
"server3" configuration stored in prefs.js was different from the one stored in
localstore.rdf.
I think this problem should be considered rare and not so relevant once it can
be solved quite easily (just deleting or editing these two files).
Just one question: it's possible to migrate from Windows Mozilla Mail to Linux
Mozilla Mail?

Best regards,

Manuel Silva
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.