Inconsistent vertical text spacing within <font size="2>

VERIFIED INVALID

Status

()

Core
Layout
--
trivial
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: Daniel Mario Vega (Restore MNG Support --> #18574), Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments, 1 obsolete attachment)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1a+) Gecko/20020714
BuildID:    2002071408

The vertical line spacing of a paragraph is inconsistent. Most of the lines are
16 pixels tall. But some are 17 or 18, with no apparent reason.

Reproducible: Always
Steps to Reproduce:
1. Go to the URL or open the test case
2. Take a spanpshot of the screen and measure the line spacing from baseline to
baseline


Actual Results:  First line is 17 pixels tall, last line is 18 pixels tall and
the the others are 16 pixels tall.

Expected Results:  All lines should be 16 pixels tall

My machine is setup to use "Small Fonts" and my Display Resolution is 96dpi
(The usual settings)

This page displays fine under Nav 4.x and MSIE. All lines are 16 pixels tall.

Also if you select the paragraph (Ctrl-A), there is a gap above the last line of
the paragraph.

I'll upload a reduced testcase and some screenshots
Created attachment 91805 [details]
Reduced testcase
Created attachment 91808 [details]
Screenshot of mozilla displaying the paragraph
Created attachment 91811 [details]
Screenshot of mozilla with selected text
Summary: Inconsistant vertical text spacing → Inconsistent vertical text spacing
I've made a new reduced testcase.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Inconsistent vertical text spacing → Inconsistent vertical text spacing within <font size="2>
Created attachment 91865 [details]
New testcase
Attachment #91805 - Attachment is obsolete: true

Comment 6

16 years ago
Your problem is right here:
<p>
    <font size="2">
^^^^---This whitespace is OUTSIDE the font tag. Thus, "size=2" doesn't affect
it, and it defaults to size=3 which is taller and makes the whole string taller
as well. Same applies to the last string.

Try the following HTML -- it doesn't have the problem described, because there's
no whitespaces left outside <font>...</font>.

==> INVALID.




<p><font size="2">
        Como en un lavadero autom&aacute;tico de coches, los
        clientes ingresan a una peque&ntilde;a cabina donde son rociados
        con un l&iacute;quido autobronceante. Se puede graduar el tono de
        acuerdo al tipo de piel y gusto del consumidor. El "tratamiento"
        ofrece un bronceado "sin parches" que dura cinco d&iacute;as. El
        sistema, desarrollado y patentado por la compa&ntilde;&iacute;a
        estadounidense Mystic Tan est&aacute; haciendo furor y amenaza
        con retirar del mercado a las peligrosas camas solares.
</font></p>



P.S. It's a well-known feature. See source of http://wesha.lib.ru for example of
HTML code that circumvents "unwanted whitespace" problem.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Verified/Invalid

You are right Wesha. It was obvious. Sorry.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.