Closed Bug 1581152 Opened Last month Closed Last month

TypeError: this.buttons.proceedDefaultAction is not a function

Categories

(Thunderbird :: Instant Messaging, defect)

defect
Not set

Tracking

(thunderbird_esr6869+ fixed, thunderbird70 fixed, thunderbird71 fixed)

RESOLVED FIXED
Thunderbird 71.0
Tracking Status
thunderbird_esr68 69+ fixed
thunderbird70 --- fixed
thunderbird71 --- fixed

People

(Reporter: clokep, Assigned: khushil324)

References

(Regression)

Details

Attachments

(1 file)

Steps to reproduce:

  1. Open the chat account preferences
  2. Double click on an existing account
  3. See error: chrome://chat/content/chat-account-richlistitem.js, line 47: TypeError: this.buttons.proceedDefaultAction is not a function

This should connect/disconnect the account. I suspect this is from de-XBL?

Likely a regression from bug 1531312.

Regressed by: 1531312
Assignee: nobody → khushil324
Status: NEW → ASSIGNED
Comment on attachment 9092707 [details] [diff] [review]
Bug-1581152_proceedDefaultAction-in-chat-corrected.patch

Works fine. Do you know if this needs uplift to 68?
Attachment #9092707 - Flags: review?(clokep) → review+
Comment on attachment 9092707 [details] [diff] [review]
Bug-1581152_proceedDefaultAction-in-chat-corrected.patch

[Approval Request Comment]
Regression caused by (bug #): bug 1531312
User impact if declined: Double clicking to connect/disconnect accounts will not work
Testing completed (on c-c, etc.): Tested locally
Risk to taking this patch (and alternatives if risky): The risk is that double clicking to connect/disconnect accounts still won't work
Attachment #9092707 - Flags: approval-comm-esr68?
Attachment #9092707 - Flags: approval-comm-beta?
Keywords: checkin-needed
Attachment #9092707 - Flags: approval-comm-esr68?
Attachment #9092707 - Flags: approval-comm-esr68+
Attachment #9092707 - Flags: approval-comm-beta?
Attachment #9092707 - Flags: approval-comm-beta+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/1ad46bfea4c7
fix invocation of proceedDefaultAction() in chat-account-richlistitem.js. r=clokep

Status: ASSIGNED → RESOLVED
Closed: Last month
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 71.0
You need to log in before you can comment on or make changes to this bug.